notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Current status

The server has been repaired, with a new power supply, for $23. I am waiting for lower COVID rates before visiting the datacenter to return it.
User login/updates are disabled as part of transition to git. Read details in our recent bog post - this is the old server.
Port details
rubygem-gitaly Auto-generated gRPC client for gitaly
13.9.0.pre.rc1 net on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 13.9.0.pre.rc1Version of this port present on the latest quarterly branch.
Maintainer: mfechner@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-06-28 08:54:19
Last Update: 2021-03-03 09:34:26
SVN Revision: 567044
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-gitaly-13.9.0.pre.rc1/catalog.mk
  2. /usr/local/share/licenses/rubygem-gitaly-13.9.0.pre.rc1/LICENSE
  3. /usr/local/share/licenses/rubygem-gitaly-13.9.0.pre.rc1/MIT
Collapse this list.
Dependency lines:
  • rubygem-gitaly>0:net/rubygem-gitaly
To install the port: cd /usr/ports/net/rubygem-gitaly/ && make install clean
To add the package: pkg install rubygem-gitaly
PKGNAME: rubygem-gitaly
Flavors: there is no flavor information for this port.
distinfo:
Packages: (move your mouse over the cells for more information)
rubygem-gitaly
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd6413.9.0.pre.rc1-
FreeBSD:11:armv6--
FreeBSD:11:i38613.9.0.pre.rc113.9.0.pre.rc1
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64--
FreeBSD:12:amd6413.9.0.pre.rc113.9.0.pre.rc1
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i38613.9.0.pre.rc113.9.0.pre.rc1
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch6413.7.0.pre.rc113.7.0.pre.rc1
FreeBSD:13:amd6413.9.0.pre.rc1-
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i38613.9.0.pre.rc1-
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch6413.9.0.pre.rc1-
FreeBSD:14:amd6413.9.0.pre.rc1-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i38613.9.0.pre.rc1-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-grpc130>=1.0<2.0 : net/rubygem-grpc130
  2. gitaly>=13.8 : devel/gitaly
  3. ruby27 : lang/ruby27
  4. gem27 : devel/ruby-gems
Patch dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Extract dependencies:
  1. ruby27 : lang/ruby27
This port is required by:
for Build
  1. www/gitlab-ce
for Run
  1. www/gitlab-ce

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. www/gitlab*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options

USES:

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.org/downloads/
Collapse this list.

Number of commits found: 27

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
03 Mar 2021 09:34:26
Original commit files touched by this commit  13.9.0.pre.rc1
Revision:567044
mfechner search for other commits by this committer
Update to 13.9.0.pre.rc1 which is required for gitlab-ce 13.9 upgrade.
06 Feb 2021 01:22:51
Original commit files touched by this commit  13.8.0.pre.rc2_1
Revision:564168
sunpoet search for other commits by this committer
Fix grpc issue in gitlab-ce

- While I'm here, use = instead of ?= because gitlab-ce does not have slave port
- Bump PORTREVISION for dependency change

gitlab-ce has some runtime issue with grpc versions, especially upb stuff.
Move all gitlab-ce dependencies to specific grpc/rubygem-grpc versions in order
to keep gitlab-ce port more robust.

The changes are as follows:
- Add devel/grpc134 (copied from devel/grpc)
- Add net/rubygem-grpc130 (copied from net/rubygem-grpc)
- Move gitlab-ce and its dependencies to grpc134 and rubygem-grpc130

Differential Revision:	https://reviews.freebsd.org/D28491
Submitted by:	sunpoet (myself)
Approved by:	mfechner
Tested by:	mfechner
27 Jan 2021 12:45:01
Original commit files touched by this commit  13.8.0.pre.rc2
Revision:563061
mfechner search for other commits by this committer
Update to 13.8.0.pre.rc2 which is required for gitlab-ce 13.8.
22 Dec 2020 16:37:37
Original commit files touched by this commit  13.7.0.pre.rc1
Revision:558921
mfechner search for other commits by this committer
Update to 13.7.0.pre.rc1 which is required for gitlab 13.7.
23 Oct 2020 04:52:08
Original commit files touched by this commit  13.5.0.pre.rc2
Revision:553076
mfechner search for other commits by this committer
Update to 13.5.0.pre.rc2 which is required for gitlab-ce 13.5.
10 Oct 2020 11:58:22
Original commit files touched by this commit  13.3.0.p.r5_1
Revision:551919
mfechner search for other commits by this committer
Switched to net/rubygem-grpc.
25 Aug 2020 13:04:07
Original commit files touched by this commit  13.3.0.p.r5
Revision:546172
mfechner search for other commits by this committer
Update to 13.3.0.pre.rc5 which is required for gitlab 13.3.
24 Jul 2020 09:14:41
Original commit files touched by this commit  13.2.0.p.r2
Revision:543227
mfechner search for other commits by this committer
Update to 13.2.0.pre.rc2 which is required for gitlab-ce 13.2.
22 Jun 2020 18:33:35
Original commit files touched by this commit  13.1.0.p.r1
Revision:539898
mfechner search for other commits by this committer
Update to 13.1.0.pre.rc1 which is required for gitlab 13.1.
04 Jun 2020 19:51:55
Original commit files touched by this commit  13.0.0.p.r1
Revision:537939
mfechner search for other commits by this committer
Update to 13.0.0.pre.rc1 which is required for gitlab-ce 13.0.
15 Apr 2020 20:36:06
Original commit files touched by this commit  12.9.0.p.r4_1
Revision:531790
mfechner search for other commits by this committer
Fixed dependency problems that caused gitaly/gitlab-ce build to fail.

PR:		245559
Reported by:	freebsd at wb9.se
28 Mar 2020 09:03:45
Original commit files touched by this commit  12.9.0.p.r4
Revision:529317
mfechner search for other commits by this committer
Update to 12.9.0.pre.rc4 which is required for gitlab-ce 12.9 upgrade.
25 Feb 2020 15:48:21
Original commit files touched by this commit  1.86.0
Revision:527087
mfechner search for other commits by this committer
Update to 1.86.0 which is required for gitlab-ce 12.8 update.
02 Feb 2020 08:26:36
Original commit files touched by this commit  1.81.0
Revision:524824
mfechner search for other commits by this committer
Update to 1.81.0 which is required for gitlab-ce 12.7.
27 Dec 2019 15:37:08
Original commit files touched by this commit  1.73.0
Revision:521001
mfechner search for other commits by this committer
Update to 1.73.0 which is required for gitlab-ce 12.6.0.
23 Nov 2019 08:45:18
Original commit files touched by this commit  1.70.0
Revision:518195
mfechner search for other commits by this committer
Update to 1.70.0 which is required for gitlab-ce 12.5.
24 Oct 2019 17:01:34
Original commit files touched by this commit  1.65.0
Revision:515476
mfechner search for other commits by this committer
net/rubygem-gitaly: upgrade to 1.65.0 required for gitlab-ce 12.4 upgrade.
09 Sep 2019 10:25:47
Original commit files touched by this commit  1.58.1
Revision:511616
mfechner search for other commits by this committer
net/rubygem-gitaly: upgrade to 1.58.1 which is required for gitlab-ce 12.2.
09 May 2018 10:43:26
Original commit files touched by this commit  0.30.0
Revision:469442
mfechner search for other commits by this committer
Changed the MAINTAINER of all my ports to have mfechner@FreeBSD.org listed.

Reviewed by:	tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D15270
04 Apr 2018 16:36:32
Original commit files touched by this commit  0.30.0
Revision:466447
mfechner search for other commits by this committer
Fixed outdated dependency for net/rubygem-gitaly.

Reviewed by:	tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D14944
02 Jan 2018 15:32:06
Original commit files touched by this commit  0.30.0
Revision:457869
swills search for other commits by this committer
net/rubygem-gitaly: update to 0.30.0

PR:		224781
Approved by:	Matthias Fechner <idefix@fechner.net> (maintainer)
05 Dec 2017 16:44:09
Original commit files touched by this commit  0.14.0
Revision:455591
tz search for other commits by this committer
GitLab and related ports maintained by me: pass maintainership to Matthias
Fechner

Matthias has proven himself as capable and enthusiastic enough to update
www/gitlab on its own - which frees much of my time. :)

I wrote an update guide for him and everybody interested in it:
http://gitlab.toco-domains.de/FreeBSD/GitLab-docu/blob/master/update/how-to-update-the-freebsd-port.md
24 Oct 2017 14:25:31
Original commit files touched by this commit  0.14.0
Revision:452774
tz search for other commits by this committer
net/rubygem-gitaly: Update from 0.8.0 to 0.14.0

Changelog: https://gitlab.com/gitlab-org/gitaly/blob/v0.14.0/CHANGELOG.md

Reviewed by: Matthias Fechner <idefix@fechner.net>
13 Sep 2017 13:44:13
Original commit files touched by this commit  0.8.0
Revision:449787
tz search for other commits by this committer
net/rubygem-gitaly: Update from 0.6.0 to 0.8.0

Changelog: https://gitlab.com/gitlab-org/gitaly/blob/v0.8.0/CHANGELOG.md

Add missing dependency devel/gitaly and adjust required version of
rubygem-google-protobuf. Older versions have a bug which make it
unusable with www/gitlab.

Reviewed by: Matthias Fechner <idefix@fechner.net>
09 Aug 2017 09:12:13
Original commit files touched by this commit  0.6.0
Revision:447610
tz search for other commits by this committer
net/rubygem-gitaly: Update from 0.5.0 to 0.6.0

Also add License and needed BUILD_DEPENDS

Sadly this version has no changelog

Submitted by: Matthias Fechner <idefix@fechner.net>, tz
06 Jul 2017 14:03:59
Original commit files touched by this commit  0.5.0
Revision:445151
tz search for other commits by this committer
net/rubygem-gitaly: Update from 0.2.1 to 0.5.0

Sadly no changelog available

Also it is now fully functional and no longer a stub
28 Jun 2017 08:54:10
Original commit files touched by this commit  0.2.1
Revision:444552
tz search for other commits by this committer
New port: net/rubygem-gitaly

Gitaly is a Git RPC service for handling all the git calls made by GitLab.

WWW: https://gitlab.com/gitlab-org/gitaly

ATTENTION: the port has currently just a subset of functions and is needed
	   in order to provide the security update of www/gitlab to 9.0

Number of commits found: 27

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
Security Policy
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
samba411Mar 28
samba412Mar 28
samba413Mar 28
linux-c7-nettleMar 27
nettleMar 27
opensslMar 26
spamassassinMar 24
giteaMar 23
giteaMar 21
dnsmasqMar 18
dnsmasq-develMar 18
gitlab-ceMar 18
minioMar 17
chromiumMar 16
libresslMar 16

12 vulnerabilities affecting 72 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2021-03-28 22:40:29


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 42809
Broken 73
Deprecated 286
Ignore 313
Forbidden 4
Restricted 137
No CDROM 71
Vulnerable 22
Expired 118
Set to expire 262
Interactive 0
new 24 hours 0
new 48 hours0
new 7 days0
new fortnight0
new month50

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2021 Dan Langille. All rights reserved.