notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Current status

The server has been repaired, with a new power supply, for $23. I am waiting for lower COVID rates before visiting the datacenter to return it.
User login/updates are disabled as part of transition to git. Read details in our recent bog post - this is the old server.
non port: UPDATING
SVNWeb

Number of commits found XX: 2438 (showing only 100 on this page)

[First Page]  «  1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11  »  [Last Page]

Sun, 23 Feb 2020
[ 10:51 zeising ] Original commit   Revision:526915
526915 UPDATING
UPDATING: improve xorg-server entry

Improve the xorg-server entry a bit, add a note about needing
xf86-input-libinput and x11/libinput, since they seem to not always be
installed when people have custom configs or options.
[ 08:08 sunpoet ] Original commit   Revision:526899
526899 UPDATING
Document the split of GNU SASL (gsasl)
Thu, 20 Feb 2020
[ 22:26 zeising ] Original commit   Revision:526594
526594 UPDATING
Add UPDATING entry for xorg-server

Add UPDATING entry for xorg-server, detailing the change of device
configuration backend.

Reminded by:	linimon, grembo
PR:		196678 (for tracking)
Fri, 7 Feb 2020
[ 13:32 lwhsu ] Original commit   Revision:525484
525484 UPDATING
525484 security/nss/Makefile
525484 security/nss/files/nss-config.in
525484 security/nss/files/nss.pc.in
525484 security/nss/pkg-plist
Reduce the duplicated 'nss' in include and lib path

From jbeich:
This appeared after r78824 which failed to adjust do-install.  Arch, Debian,
Gentoo, OpenBSD use include/nss/, Fedora uses include/nss3/, NetBSD/PkgSrc
uses include/nss/nss/.

PR:		243835
Reviewed by:	jbeich
Differential Revision:	https://reviews.freebsd.org/D23424
Tue, 4 Feb 2020
[ 14:03 adamw ] Original commit   Revision:525167
525167 UPDATING
525167 editors/vim/Makefile
525167 editors/vim/distinfo
vim: Update to patchlevel 205 and add PYTHON option

When python is built with DEBUG, vim fails to build. In fixing this
case, note that vim will now fail to build if python or vim is build
with DEBUG and the other isn't.

This also highlighted that python support is being kludged. The
PYTHON2 and PYTHON3 options have been combined into a single PYTHON
option that builds with the default python. Consequently, it is no
longer possible to build vim with both py2 and py3 support. I can't
name any modern high-usage python-based plugin that requires 2.7,
so hopefully this only messes up things for a very small minority.

Thanks to koobs for the prompt to combine these options. I've been
wanting to do this for a while now.

PR:		243606
Submitted by:	novel
Thu, 30 Jan 2020
[ 05:04 lwhsu ] Original commit   Revision:524628
524628 UPDATING
Remove trailing whitespace
Mon, 27 Jan 2020
[ 19:47 netchild ] Original commit   Revision:524410
524410 UPDATING
Improve the 20191216 entry. This may or may not cover the 20200113 entry.
At least it covers some cases like gdb or gobject-introspection I
encountered.
Sun, 26 Jan 2020
[ 17:42 kwm ] Original commit   Revision:524224
524224 MOVED
524224 Mk/bsd.gstreamer.mk
524224 UPDATING
524224 audio/Makefile
524224 audio/gstreamer1-plugins-pulse/Makefile
524224 audio/gstreamer1-plugins-spc
524224 audio/gstreamer1-plugins-webrtcdsp/Makefile
524224 devel/orc/Makefile
524224 devel/orc/distinfo
524224 devel/orc/files/patch-orc-orccpu_powerpc.c

(Only the first 10 of 82 ports in this commit are shown above. View all ports for this commit)
Update gstreamer1 to 1.16.2.

- The spc plugin was removed inflavor for the gsm plugin.
- Added in tree qt plugin.

Changelog: https://gstreamer.freedesktop.org/releases/1.16/#1.16.2

Update net-im/fractal to 4.2.2 to support GStreamer 1.16 (approved by
maintainer)

Thanks to antoine@ for the exp-run.

PR:		239386
[ 15:38 danilo ] Original commit   Revision:524182
524182 UPDATING
524182 sysutils/helm/Makefile
524182 sysutils/helm/distinfo
524182 sysutils/helm/pkg-message
- Update to 3.0.2
- Add UPDATING note about the incompatibility with Helm 2
Mon, 13 Jan 2020
[ 13:25 timur ] Original commit   Revision:522889
522889 UPDATING
Add a note about need of additional update of Samba-related ports in case of
Python 3 upgrade.
[ 06:03 jbeich ] Original commit   Revision:522856
522856 UPDATING
www/firefox: document Capsicum usage via UPDATING

PR:		243252
Reported by:	Jakub Lach
Analyzed by:	Greg V
Tue, 7 Jan 2020
[ 04:55 jrm ] Original commit   Revision:522315
522315 Mk/Uses/emacs.mk
522315 UPDATING
522315 audio/emms/Makefile
522315 cad/dinotrace/Makefile
522315 cad/verilog-mode.el/Makefile
522315 databases/bbdb/Makefile
522315 deskutils/howm/Makefile
522315 devel/cask/Makefile
522315 devel/clojure-cider/Makefile
522315 devel/dash.el/Makefile

(Only the first 10 of 81 ports in this commit are shown above. View all ports for this commit)
editors/emacs-devel: Update to latest master branch commit, 4f2b415

This update includes an Emacs major version change from 27.0.50 to 28.0.50.
Ports that may depend on editors/emacs-devel must chase this update
with a PORTREVISION bump.

Submitted by:	ashish (maintainer)
Differential Revision:	https://reviews.freebsd.org/D23012
Mon, 6 Jan 2020
[ 23:03 olgeni ] Original commit   Revision:522300
522300 UPDATING
UPDATING: add note about net/gnatsd becoming net/nats-server.
Wed, 1 Jan 2020
[ 16:42 brnrd ] Original commit   Revision:521745
521745 MOVED
521745 Mk/Uses/ssl.mk
521745 UPDATING
521745 security/Makefile
521745 security/openssl
521745 security/openssl/Makefile
521745 security/openssl111
security/openssl111: Rename to openssl

 - Honoring promise from DEPRECATED message
 - Unbreak people's builds

PR:		243014
MFH:		2020Q1
Thu, 26 Dec 2019
[ 21:09 fernape ] Original commit   Revision:520953
520953 UPDATING
520953 sysutils/dsbmd/Makefile
520953 sysutils/dsbmd/distinfo
sysutils/dsbmd: update to 1.10

From ChangeLog: https://freeshell.de/~mk/projects/dsbmd-relnotes.html

* The fuse daemon to mount MTP devices has been changed to
sysutils/fusefs-jmtpfs
  (Entry added in UPDATING)

* The environment variables DSBMD_USB_UNIT and DSBMD_USB_ADDR has been added
which
  can be used by commands in dsbmd.conf

PR:	242888
Submitted by:	mk@nic-nac-project.org (maintainer)
Wed, 25 Dec 2019
[ 15:14 jbeich ] Original commit   Revision:520876
520876 UPDATING
Let users cleanup after r520872
Sun, 22 Dec 2019
[ 11:58 netchild ] Original commit   Revision:520614
520614 UPDATING
Add info about openhab2.
Sat, 21 Dec 2019
[ 12:20 netchild ] Original commit   Revision:520560
520560 UPDATING
Update the python entry with instructions for portmaster users.
Tue, 17 Dec 2019
[ 09:40 antoine ] Original commit   Revision:520321
520321 UPDATING
Add some instructions that may help the python upgrade
Mon, 16 Dec 2019
[ 06:46 antoine ] Original commit   Revision:520223
520223 UPDATING
Add updating entry for python
Wed, 4 Dec 2019
[ 16:04 brnrd ] Original commit   Revision:519026
519026 UPDATING
519026 mail/nextcloud-mail/Makefile
519026 mail/nextcloud-mail/distinfo
519026 mail/nextcloud-mail/pkg-plist
mail/nextcloud-mail: Update to 0.20.0
Tue, 26 Nov 2019
[ 18:37 kai ] Original commit   Revision:518476
518476 UPDATING
518476 net/py-urllib3/Makefile
518476 net/py-urllib3/distinfo
518476 net/py-urllib3/files/patch-setup.py
518476 net/py-urllib3/files/pkg-message.in
net/py-urllib3: Update to 1.25.6

* Convert the RUN_DEPENDS into separate OPTIONS as they are listed as extra
  dependencies in setup.py.  Also set those as default that contain the
  previous RUN_DEPENDS to allow a clean transition.

* Remove the Python-specific version limitation for security/py-certifi
  because it's required for all Python versions.

* Also remove the info about the broken IPv6 support of net/py-socks (was
  broken in 1.5.7) and the relevant patch as both are obsolete.

* Update the TEST_DEPENDS and add a "do-test" target to make future QA easier.

Please note that a MFH won't be done as it didn't get an approval because
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Mon, 25 Nov 2019
[ 11:01 bofh ] Original commit   Revision:518397
518397 UPDATING
518397 emulators/qemu/Makefile
518397 emulators/qemu/distinfo
518397 emulators/qemu/files/patch-Makefile
518397 emulators/qemu/files/patch-configure
518397 emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
518397 emulators/qemu/files/patch-include_net_net.h
518397 emulators/qemu/files/patch-include_qemu_atomic.h
518397 emulators/qemu/files/patch-net_tap-bsd.c
518397 emulators/qemu/files/patch-qemu-doc.texi

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
emulators/qemu: Updating version 3.1.1.1=>4.1.1

- 3.1.X branch has been moved to emulators/qemu31

Relnotes:	https://wiki.qemu.org/ChangeLog/4.1
Sun, 24 Nov 2019
[ 18:57 dbaio ] Original commit   Revision:518350
518350 UPDATING
518350 irc/eggdrop/Makefile
518350 irc/eggdrop/distinfo
518350 irc/eggdrop/files/patch-eggdrop.conf
518350 irc/eggdrop/files/patch-src__Makefile.in
518350 irc/eggdrop/files/patch-src_eggdrop.h
518350 irc/eggdrop/files/patch-src_main.c
518350 irc/eggdrop/files/patch-src_match.c
518350 irc/eggdrop/files/patch-src_mod_share.mod__share.c
518350 irc/eggdrop/files/patch-src_modules.c

(Only the first 10 of 15 ports in this commit are shown above. View all ports for this commit)
irc/eggdrop: Update to 1.8.4

Changelog:	https://raw.githubusercontent.com/eggheads/eggdrop/v1.8.4/NEWS
Thu, 21 Nov 2019
[ 19:27 osa ] Original commit   Revision:518107
518107 UPDATING
518107 databases/Makefile
518107 databases/p5-AnyEvent-Redis/Makefile
518107 databases/p5-Redis-Fast/Makefile
518107 databases/py-redis/Makefile
518107 databases/py-redis2/Makefile
518107 databases/redis-devel/Makefile
518107 databases/redis/Makefile
518107 databases/redis/distinfo
518107 databases/redis/files/extra-patch-src-Makefile.lua

(Only the first 10 of 30 ports in this commit are shown above. View all ports for this commit)
Repocopy the databases/redis to the databases/redis4 to update
the databases/redis port to the latest stable version, 5.0.6.

PR:		241526
Reviewed by:	portmgr (adamw)
Approved by:	portmgr (adamw)
Differential Revision:	https://reviews.freebsd.org/D22336
Sun, 3 Nov 2019
[ 22:38 bhughes ] Original commit   Revision:516611
516611 UPDATING
516611 www/node/Makefile
516611 www/node/distinfo
516611 www/node/files/patch-node.gypi
www/node: Update 12.13.0 -> 13.0.0

Update to the latest major release of Node.js, regenerating patches
with `make makepatch` while here.

https://nodejs.org/en/blog/release/v13.0.0/

Sponsored by:	Miles AS
Tue, 29 Oct 2019
[ 14:36 jpaetzel ] Original commit   Revision:515982
515982 UPDATING
515982 emulators/open-vm-tools/Makefile
515982 emulators/open-vm-tools/distinfo
515982 emulators/open-vm-tools/files/patch-modules_freebsd_vmmemctl_os.c
515982 emulators/open-vm-tools/files/patch-modules_freebsd_vmxnet_if__vxn.c
515982 emulators/open-vm-tools/files/patch-modules_freebsd_vmxnet_net__compat.h
515982 emulators/open-vm-tools/pkg-plist
Update to version 11.0.1

The biggest change is the removal of vmxnet from this package.  This means you
*must* be using the vmx driver included in FreeBSD or your networking will fail
after this update.  This is a danger for people who are running unsupported
versions
of FreeBSD but could also affect people who are running custom kernels that have
removed vmx from them.

This update reduces our patchset by taking advantage of patches submitted
upstream.

Sponsored by:	Panzura
Sat, 26 Oct 2019
[ 22:00 kai ] Original commit   Revision:515731
515731 UPDATING
515731 www/qt5-webengine/Makefile
515731 www/qt5-webengine/distinfo
515731 www/qt5-webengine/files/freebsd.pri
515731 www/qt5-webengine/files/patch-clang
515731 www/qt5-webengine/files/patch-configure.pri
515731 www/qt5-webengine/files/patch-mkspecs_features_functions.prf
515731 www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
515731 www/qt5-webengine/files/patch-src_3rdparty_chromium_base_BUILD.gn
515731 www/qt5-webengine/files/patch-src_3rdparty_chromium_base_allocator_partition__allocator_page__allocator.cc

(Only the first 10 of 260 ports in this commit are shown above. View all ports for this commit)
www/qt5-webengine: Update to 5.13.0

Under the hood runs Chromium 73.0.3683.105 with applied security fixes from
Chrome up to version 74.0.3729.157.

Most of the patches were synced with www/chromium 73.0.3683.103 (= r498089)
with some re-added/modified patches from r497877 and r499210 to get also
successful builds on aarch64. Some tweaking might still be needed to get
positive build results on the armv7 architecture.

Other notable changes:

* GN keywords "use_system_{libusb,libcxx}" aren't used anymore thus both
  were removed from the FreeBSD specific qmake file "freebsd.pri".
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Fri, 25 Oct 2019
[ 09:30 danfe ] Original commit   Revision:515590
515590 UPDATING
- Add a note about `x11/nvidia-driver' split in r515584
- Consistently spell "users" lowercased after "AFFECTS:"
[ 08:50 danfe ] Original commit   Revision:515587
515587 UPDATING
Some minor grammar and formatting fixes.
Mon, 21 Oct 2019
[ 04:42 meta ] Original commit   Revision:515080
515080 UPDATING
UPDATING: Add category/portname for KDE Plasma Desktop in 20191016

as well as r514569.

PR:		241169
Submitted by:	Yuichiro NAITO (naito.yuichiro@gmail.com)
Approved by:	portmgr blanket
Wed, 16 Oct 2019
[ 09:54 tcberner ] Original commit   Revision:514577
514577 Mk/Uses/kde.mk
514577 UPDATING
514577 audio/plasma5-plasma-pa/distinfo
514577 audio/plasma5-plasma-pa/pkg-plist
514577 deskutils/plasma5-milou/Makefile
514577 deskutils/plasma5-milou/distinfo
514577 deskutils/plasma5-milou/pkg-plist
514577 deskutils/plasma5-sddm-kcm/distinfo
514577 deskutils/plasma5-sddm-kcm/pkg-plist
514577 devel/plasma5-khotkeys/distinfo

(Only the first 10 of 79 ports in this commit are shown above. View all ports for this commit)
Update KDE's Plasma Desktop to 5.17

Plasma 5.17 is the version where the desktop anticipates your needs. Night
Color, the color-grading system that relaxes your eyes when the sun sets, has
landed for X11. Your Plasma desktop also recognizes when you are giving a
presentation, and stops messages popping up in the middle of your slideshow. If
you are using Wayland, Plasma now comes with fractional scaling, which means
that you can adjust the size of all your desktop elements, windows, fonts and
panels perfectly to your HiDPI monitor.

The best part? All these improvements do not tax your hardware! Plasma 5.17 is
as lightweight and thrifty with resources as ever.

Important startup change:
	With Plasma 5.17 the startup script has been renamed. People who use the
	.xinitrc method to start Plasma have to call the new binary.

	Previously:
	     exec ck-launch-session startkde
	Change to:
	     exec ck-launch-session startplasma-x11

Announcement:
	https://kde.org/announcements/plasma-5.17.0.php
[ 01:26 meta ] Original commit   Revision:514569
514569 UPDATING
AFFECTS line should contain portcategory/portname

so that automated tools can parse it as easily as possible, according to
Porter's handbook 11.2.1 [1].

[1]
https://www.freebsd.org/doc/en/books/porters-handbook/moved-and-updating-files.html

PR:		241169
Submitted by:	Yuichiro NAITO <naito.yuichiro@gmail.com>
Approved by:	portmgr blanket
Tue, 15 Oct 2019
[ 10:45 madpilot ] Original commit   Revision:514509
514509 UPDATING
Fix typo.
Mon, 14 Oct 2019
[ 16:06 vsevolod ] Original commit   Revision:514463
514463 UPDATING
514463 mail/rspamd-devel/Makefile
514463 mail/rspamd-devel/distinfo
514463 mail/rspamd-devel/files/patch-CMakeLists.txt
514463 mail/rspamd-devel/pkg-plist
514463 mail/rspamd/Makefile
514463 mail/rspamd/distinfo
514463 mail/rspamd/files/patch-CMakeLists.txt
514463 mail/rspamd/files/patch-contrib_lua-torch_torch7_lib_TH_CMakeLists.txt
514463 mail/rspamd/files/patch-src_libutil_mem__pool.c

(Only the first 10 of 12 ports in this commit are shown above. View all ports for this commit)
mail/rspamd:
- Update to 2.0
- Add upstream patches to fix crash due to constructors init order
- Remove sample configuration files as default configuration files are NOT
intended for modification by users and SHOULD be overwritten on port upgrade.
- Remove NO_SHARED CMake flag as it is on by default
- Add notes to UPDATING

mail/rspamd-devel:
- Update to 2.1.a1.20191014
- Remove sample configuration files as default configuration files are NOT
intended for modification by users and SHOULD be overwritten on port upgrade.
- Add notes to UPDATING

PR:		241204
Submitted by:	Alexander Moisseev <moiseev at mezonplus.ru>
Reported by:	Yasuhiro KIMURA <yasu at utahime.org>
Wed, 2 Oct 2019
[ 08:46 bapt ] Original commit   Revision:513559
513559 UPDATING
513559 textproc/groff/Makefile
513559 textproc/groff/files/patch-configure
513559 textproc/groff/pkg-message
513559 textproc/groff/pkg-plist
groff: remove X11 option and dependency

Now that groff is required for manpages that are not supported by mandoc
the default dependency on X11 has become a big concern for many people.

From now the entire X11 option has been removed as it is only needed for
legacy part of groff that have little end user value.

The other part that was dragging in all the X11 dependencies was the ghostscript
dependency which is needed for 2 cases:
1. find the path of the urw fonts which is needed for pdf generation. the
configure script has been patched to stop using ghostscript to find that path,
but directly use the one provided.
2. the html driver which calls at runtime the gs binary along with some binaries
provided by the netpbm package. Given how little use it is, add a message to
tell the users to manually install ghostscript and netpbm as optional dependency
if they do need to use groff -Thtml.

Requested by:	many
Mon, 30 Sep 2019
[ 14:55 kai ] Original commit   Revision:513395
513395 UPDATING
513395 net-mgmt/netbox/Makefile
513395 net-mgmt/netbox/distinfo
513395 net-mgmt/netbox/files/netboxrc.sample.in
513395 net-mgmt/netbox/files/pkg-message.in
513395 net-mgmt/netbox/pkg-plist
net-mgmt/netbox: Update to 2.6.5

* Introduce EXAMPLES option which installs a sample rc script to the example
  location.  Using the script will eliminate the need for
  sysutils/py-supervisor for those who run NetBox as a system service. [1]

  If there's a lot of interest it can also be installed in near future as
  regular rc script.

* Consolidate keywords in pkg-message to avoid accidental deletion of these.

Notable changes since 2.5.13:

* Improved performance via Caching through Redis
* Support for Power Panels and Feeds
* Introduction of view-only permissions
* Ability to create custom links under the admin UI
* Support for Prometheus metrics
* Many other enhancements and bug fixes

https://github.com/netbox-community/netbox/blob/v2.6.5/CHANGELOG.md

Submitted by:	Thomas Kurschel (via private email) [1]
Fri, 27 Sep 2019
[ 17:55 bofh ] Original commit   Revision:513050
513050 UPDATING
513050 emulators/Makefile
513050 emulators/qemu-devel/Makefile
513050 emulators/qemu-devel/distinfo
513050 emulators/qemu-devel/pkg-plist
513050 emulators/qemu40
513050 emulators/qemu40/Makefile
emulators/qemu-devel: Update version 4.0.0=>4.1.0

- Merge 4.0.X branch into emulators/qemu40
- See UPDATING for more info
[ 09:00 madpilot ] Original commit   Revision:513008
513008 UPDATING
513008 x11-wm/xfce4-session/Makefile
513008 x11-wm/xfce4-session/files/patch-scripts_xscreensaver.desktop.in
513008 x11-wm/xfce4-session/files/pkg-message.in
513008 x11/xfce4-screensaver/Makefile
- Make xfce4-session install the xscreensaver.desktop session startup
  file disabled by default
- Modify name of program in .desktop file for xfce4-screensaver,
  so that the UI does not show two identical lines when both it and
  xscreensaver are installed
- Add UPDATING note and update xfce4-session pkg-message to explain
  the issue to users

PR:		240804, 240810, 240811
Submitted by:	John <jlmales@gmail.com>
Fri, 20 Sep 2019
[ 15:09 0mp ] Original commit   Revision:512417
512417 UPDATING
512417 net-mgmt/pushgateway/Makefile
512417 net-mgmt/pushgateway/distinfo
512417 net-mgmt/pushgateway/files/pushgateway.in
512417 net-mgmt/pushgateway/pkg-plist
Update to v0.9.1

Changelogs:
- https://github.com/prometheus/pushgateway/releases/tag/v0.9.1
- https://github.com/prometheus/pushgateway/releases/tag/v0.9.0
- https://github.com/prometheus/pushgateway/releases/tag/v0.7.0
- https://github.com/prometheus/pushgateway/releases/tag/v0.5.2
- https://github.com/prometheus/pushgateway/releases/tag/v0.5.1
- https://github.com/prometheus/pushgateway/releases/tag/v0.5.0
- https://github.com/prometheus/pushgateway/releases/tag/v0.4.0

The new persistent storage format is not backwards compatible. See the
changelogs for details.

- Define LICENSE_FILE.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Sat, 14 Sep 2019
[ 14:26 rene ] Original commit   Revision:512017
512017 MOVED
512017 UPDATING
512017 net-p2p/Makefile
512017 net-p2p/zetacoin-daemon
512017 net-p2p/zetacoin-daemon/Makefile
512017 net-p2p/zetacoin-utils
512017 net-p2p/zetacoin-utils/Makefile
512017 net-p2p/zetacoin/Makefile
512017 net-p2p/zetacoin/distinfo
512017 net-p2p/zetacoin/files/patch-src_Makefile.bench.include

(Only the first 10 of 20 ports in this commit are shown above. View all ports for this commit)
net-p2p/zetacoin: fix build with current boost.

Resurrect -nox11 slave port as -daemon slave port.
Split off cli and tx utilities from main port into -utils slave port.

PR:		237017
Submitted by:	Daniel Morante
Reported by:	jbeich
Wed, 11 Sep 2019
[ 17:53 netchild ] Original commit   Revision:511830
511830 UPDATING
511830 security/bastillion/Makefile
511830 security/bastillion/files/pkg-message.in
511830 security/bastillion/pkg-plist
 - Add update tool.
 - Add update instructions (datastore needs to be updated).
 - Convert pkg-message to UCL format.
 - Rework plist generation target.
Mon, 9 Sep 2019
[ 05:08 mfechner ] Original commit   Revision:511605
511605 Mk/bsd.default-versions.mk
511605 UPDATING
Switch default version of Ruby from 2.5 to 2.6.

For detailed list of changes, please check the Ruby website:
https://www.ruby-lang.org/en/news/2018/12/25/ruby-2-6-0-released/

How to upgrade is described in UPDATING entry 20190909.

Exp-Run:	https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=240094

Thanks to:	antoine, sunpoet
Fri, 6 Sep 2019
[ 23:25 dbaio ] Original commit   Revision:511379
511379 UPDATING
511379 devel/py-fabric/Makefile
511379 devel/py-fabric/distinfo
511379 devel/py-fabric/files
511379 devel/py-fabric/pkg-descr
devel/py-fabric: Update to 2.5.0

Fabric 2 is not at 100% feature parity with 1.x! Some features have been
explicitly dropped, but others simply have not been ported over yet,
either due to time constraints or because said features need to be
re-examined in a modern context.

More information at:
https://www.fabfile.org/upgrading.html#upgrading
https://www.fabfile.org/upgrading.html#upgrade-specifics

Changelog:	https://www.fabfile.org/changelog.html

Reviewed by:	koobs (maintainer)
Approved by:	koobs (maintainer)
Differential Revision:	https://reviews.freebsd.org/D20683
Fri, 30 Aug 2019
[ 07:50 mfechner ] Original commit   Revision:510253
510253 UPDATING
510253 www/gitlab-ce/Makefile
510253 www/gitlab-ce/distinfo
510253 www/gitlab-ce/files/gitlab.in
510253 www/gitlab-ce/files/patch-Gemfile
510253 www/gitlab-ce/files/patch-config_gitlab.yml.example
510253 www/gitlab-ce/files/patch-config_initializers_1__settings.rb
510253 www/gitlab-ce/files/patch-config_puma.rb.example
510253 www/gitlab-ce/pkg-message
510253 www/gitlab-ce/pkg-plist
www/gitlab-ce: Upgrade to next major version 12.1

It requires PostgreSQL version 10.7, so make sure you upgrade PostgreSQL first.
I recommand to go to version 11 as described in UPDATING entry 20190829.

MySQL support was now completely removed upstream.

Changelogs:
https://about.gitlab.com/2019/07/22/gitlab-12-1-released/
https://about.gitlab.com/2019/07/24/gitlab-12-1-1-released/
https://about.gitlab.com/2019/07/29/security-release-gitlab-12-dot-1-dot-2-released/
https://about.gitlab.com/2019/07/31/gitlab-12-1-3-released/
https://about.gitlab.com/2019/08/06/gitlab-12-1-4-released/
https://about.gitlab.com/2019/08/12/critical-security-release-gitlab-12-dot-1-dot-6-released/
https://about.gitlab.com/2019/08/29/security-release-gitlab-12-dot-2-dot-3-released/
[ 07:30 tz ] Original commit   Revision:510244
510244 UPDATING
UPDATING: Correct and improve wording of PostgreSQL update

It stated "prevent" while i meant "preserve".

Submitted by:	David Magda <dmagda@ee.ryerson.ca>
Thu, 29 Aug 2019
[ 21:29 tz ] Original commit   Revision:510189
510189 Mk/bsd.default-versions.mk
510189 UPDATING
Switch default version of PostgreSQL from 9.5 to 11

Two important changes arise with it:
- Default user switches from "pgsql" to "postgres"
- Default data-dir switches from "/usr/local/pgsql/data" to
"/var/db/postgres/data11"

Also add a migration procedure, which takes the user-switch into account by
preventing
it on database-side.

Exp-Run: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239514

Thanks to: tobik, antoine, mfechner

Sponsored by:	Professionelles Bounce Management
Fri, 16 Aug 2019
[ 09:25 ashish ] Original commit   Revision:509070
509070 UPDATING
509070 net-im/ejabberd/Makefile
509070 net-im/ejabberd/distinfo
509070 net-im/ejabberd/files/pkg-message.in
509070 net-im/ejabberd/pkg-plist
- Update to 19.08
- Remove RIAK option as support is removed upstream
- Add a note to UPDATING for the same
Wed, 14 Aug 2019
[ 19:59 amdmi3 ] Original commit   Revision:508965
508965 UPDATING
Remove trailing whitespace
Mon, 12 Aug 2019
[ 14:05 mat ] Original commit   Revision:508737
508737 UPDATING
Add an entry for the Perl default version change.
Fri, 2 Aug 2019
[ 10:43 gerald ] Original commit   Revision:507866
507866 UPDATING
Fix tijl's address in the 20190710 entry.
Thu, 1 Aug 2019
[ 22:16 dvl ] Original commit   Revision:507834
507834 UPDATING
507834 www/ot-recorder/Makefile
507834 www/ot-recorder/files/patch-config.mk
507834 www/ot-recorder/pkg-plist
HEADS UP: the data directory is moving from /var/spool to /var/db
to confirm to man hier.  An entry has been added to UPDATING.

Other changes:

* configuration file is now chmod 640
* data diretory is now chmod 750
* create the missing /var/run/ot-recorder for the PID
Sun, 28 Jul 2019
[ 21:00 kai ] Original commit   Revision:507532
507532 UPDATING
507532 net-im/py-matrix-synapse/Makefile
507532 net-im/py-matrix-synapse/distinfo
507532 net-im/py-matrix-synapse/files/patch-python_dependencies.py
net-im/py-matrix-synapse: Update to 1.2.1

* Remove the EMAIL option and convert the dependencies of it as general
  runtime requirements.

While I'm here:
* Remove superfluous occurrences of "+=" from PLIST_SUB, SUB_LIST and the
  *_RUN_DEPENDS option helpers because there are no previous definitions of
  those variables.
* Remove workaround for devel/py-msgpack from the post-patch target that is
  no longer required.
* Do some cleanup and place variables to their intended locations.

Changelog:

* Note: The support for Python 2.7 was dropped with the 1.1.0 release!

https://github.com/matrix-org/synapse/releases/tag/v1.2.1

PR:		239013
Submitted by:	Sascha Biberhofer <ports@skyforge.at> (maintainer)
MFH:		2019Q3
Security:	38d2df4d-b143-11e9-87e7-901b0e934d69
Wed, 17 Jul 2019
[ 10:37 egypcio ] Original commit   Revision:506796
506796 UPDATING
506796 sysutils/py-borgmatic/Makefile
sysutils/py-borgmatic: move borgmatic's default config dir to ${PREFIX}

PR:		239002
Wed, 10 Jul 2019
[ 14:40 tijl ] Original commit   Revision:506352
506352 Mk/Uses/linux.mk
506352 Mk/bsd.default-versions.mk
506352 UPDATING
506352 benchmarks/linux-vdbench/Makefile
506352 benchmarks/linux-vdbench/pkg-plist
506352 devel/fb-adb/Makefile
506352 devel/linux-c6-devtools/Makefile
506352 devel/linux-c7-devtools/Makefile
506352 emulators/linux-c7/Makefile
506352 emulators/linux_base-c6/Makefile

(Only the first 10 of 17 ports in this commit are shown above. View all ports for this commit)
On amd64 adding DEFAULT_VERSIONS+=linux=c6 to /etc/make.conf made Linux
infrastructure ports (linux_base-c6 and linux-c6*) install i386 CentOS 6
packages.  Using c6_64 instead of c6 made them install mixed amd64/i386
CentOS 6 packages and allowed Linux application ports to install amd64
binaries when available.  The i386-only configuration was only useful for
users of x11/nvidia-driver* which didn't provide Linux amd64 emulation
until recently.

With x11/nvidia-driver* now supporting Linux amd64 there's no longer a
need for i386-only Linux on amd64.  Let DEFAULT_VERSIONS+=linux=c6 make
Linux infrastructure ports install mixed amd64/i386 CentOS 6 packages,
like c6_64 before, and remove support for c6_64 as a value.

Replace LINUX_ARCH with ARCH everywhere because they are always the same
now.
Sun, 7 Jul 2019
[ 18:22 olgeni ] Original commit   Revision:506152
506152 UPDATING
Fix a few typos in UPDATING.
[ 10:03 mfechner ] Original commit   Revision:506124
506124 UPDATING
506124 www/gitlab-ce/Makefile
506124 www/gitlab-ce/distinfo
506124 www/gitlab-ce/files/patch-Gemfile
506124 www/gitlab-ce/pkg-message
506124 www/gitlab-ce/pkg-plist
Upgrade to www/gitlab-ce version 12.0.3.
This is a major upgrade at required version 11.11.5 to be installed before.

Make sure you follow the UPDATING entry.

Changelog:
https://about.gitlab.com/2019/06/22/gitlab-12-0-released/
Fri, 5 Jul 2019
[ 20:47 netchild ] Original commit   Revision:505936
505936 UPDATING
505936 net/serviio/Makefile
505936 net/serviio/distinfo
505936 net/serviio/pkg-plist
Update serviio to v2.0.
Mon, 1 Jul 2019
[ 07:43 ale ] Original commit   Revision:505549
505549 Mk/Uses/mysql.mk
505549 Mk/bsd.default-versions.mk
505549 UPDATING
505549 audio/amarok/Makefile
505549 audio/amarok/files/patch-cmake_modules_FindMySQL.cmake
505549 databases/apq-mysql/Makefile
505549 databases/ateam_mysql_ldap_auth/Makefile
505549 databases/mroonga/Makefile
505549 databases/mysac/Makefile
505549 databases/mysql-connector-odbc/Makefile

(Only the first 10 of 19 ports in this commit are shown above. View all ports for this commit)
Update default MySQL version to 5.7.

PR:		238365
Submitted by:	ale
Exp-run by:	antoine
Approved by:	portmgr (antoine)
Sun, 30 Jun 2019
[ 23:09 timur ] Original commit   Revision:505523
505523 UPDATING
Add two entries about upgradinf from previous versions of Samba to Samba 4.10.
Wed, 19 Jun 2019
[ 23:11 timur ] Original commit   Revision:504602
504602 UPDATING
Add a note about upgrading procedure for the talloc, tevent, tdb and
samba4[6-8].
Thu, 13 Jun 2019
[ 08:44 kai ] Original commit   Revision:504068
504068 UPDATING
504068 www/qt5-webengine/Makefile
504068 www/qt5-webengine/files/patch-clang
504068 www/qt5-webengine/files/patch-src_3rdparty_chromium_media_capture_video_create__video__capture__device__factory.cc
504068 www/qt5-webengine/files/patch-src_3rdparty_chromium_media_capture_video_shared__memory__handle__provider.cc
504068 www/qt5-webengine/files/patch-src_3rdparty_chromium_media_capture_video_shared__memory__handle__provider.h
504068 www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_webrtc_webrtc.gni
www/qt5-webengine: Enable support for WebRTC and video capture devices

When accessing video capture devices warnings like below are emitted [2]:

[40533:463527936:0420/214650.072475:ERROR:create_video_capture_device_factory.cc(58)]
Not implemented reached in std::unique_ptr<VideoCaptureDeviceFactory>
media::(anonymous
namespace)::CreatePlatformSpecificVideoCaptureDeviceFactory(scoped_refptr<base::SingleThreadTaskRunner>)

Also websites that want to access the camera, microphone, etc. exhibit
broken behavior, e.g. no dialogs to permit access on the desired capture
devices come up. [1]

Thus add the related patches from www/chromium [2] that enable support for
video capture devices and explicitly activate the WebRTC feature. [1]

PR:		236915 [1], 237423 [2]
Submitted by:	cmt [2]
Reported by:	thea20lineisameme@protonmail.com [1]
Reviewed by:	rakuco, tcberner (kde), Lorenzo Salvadore
Approved by:	tcberner (kde)
Differential Revision:	https://reviews.freebsd.org/D19900
Tue, 11 Jun 2019
[ 16:07 rodrigo ] Original commit   Revision:503968
503968 UPDATING
503968 net/routinator/Makefile
503968 net/routinator/distinfo
Upgrade  net/routinator from 0.3.3 to O.4.0

Change log: https://github.com/NLnetLabs/routinator/releases/tag/v0.4.0

If you have been using previous releases of net/routinator check UPDATING file.

- Add an entry in UPDATING and fix typo in the previous entry

PR:		238335
Submitted by:	Jaap Akkerhuis <jaap@NLnetLabs.nl>
Tue, 4 Jun 2019
[ 14:17 antoine ] Original commit   Revision:503475
503475 Mk/bsd.default-versions.mk
503475 UPDATING
503475 audio/musicpd/Makefile
503475 audio/xmms2/Makefile
503475 devel/gnome-vfs/Makefile
503475 devel/gvfs/Makefile
503475 devel/kio-extras/Makefile
503475 emulators/qemu-devel/Makefile
503475 emulators/qemu-sbruno/Makefile
503475 emulators/qemu/Makefile

(Only the first 10 of 37 ports in this commit are shown above. View all ports for this commit)
Switch default version of samba from 4.7 to 4.8

With hat:	portmgr
Sun, 2 Jun 2019
[ 13:55 thierry ] Original commit   Revision:503314
503314 UPDATING
503314 www/tt-rss/Makefile
503314 www/tt-rss/distinfo
503314 www/tt-rss/pkg-plist
Update to d36b64d8a g20190531

- Update to d36b64d8a g20190531
- pkg-plist cleanup
- require intl extension - update UPDATING for possible restart

PR:		238286
Submitted by:	maintainer
Wed, 22 May 2019
[ 21:15 dch ] Original commit   Revision:502290
502290 UPDATING
502290 sysutils/graylog/Makefile
502290 sysutils/graylog/distinfo
502290 sysutils/graylog/files/graylog.in
502290 sysutils/graylog/files/graylog_logging.xml.in
502290 sysutils/graylog/files/log4j2.xml.in
502290 sysutils/graylog/files/pkg-message.in
502290 sysutils/graylog/files/server.conf.in
502290 sysutils/graylog/pkg-plist
sysutils/graylog: update 2.4.6 to 3.0.2

- align file locations to match new upstream config
- amend messages and UPDATING to alert users
- use upstream sample files for default configuration
- MAINTAINER timeout

Approved by:	jrm (mentor)
Differential Revision:	https://reviews.freebsd.org/D20021
Mon, 13 May 2019
[ 14:32 danfe ] Original commit   Revision:501572
501572 UPDATING
Spell portupgrade(1) command correctly, consistently use plural form of
the word "users", and wrap one overly long line while I'm here.
Thu, 9 May 2019
[ 16:06 danfe ] Original commit   Revision:501116
501116 UPDATING
Fix some typos and remove EOL whitespace.
Mon, 6 May 2019
[ 08:51 joneum ] Original commit   Revision:500902
500902 UPDATING
500902 www/gitea/Makefile
500902 www/gitea/distinfo
500902 www/gitea/files/app.ini.sample.in
500902 www/gitea/pkg-message
500902 www/gitea/pkg-plist
www/gitea: Update to 1.8.0

Changelog: https://blog.gitea.io/2019/04/gitea-1.8.0-is-released/

 - Add UPDATING

PR:		237734
Submitted by:	stb@lassitu.de (maintainer)
MFH:		2019Q2
Security:	a1de4ae9-6fda-11e9-9ba0-4c72b94353b5
Sponsored by:	Netzkommune GmbH
Wed, 24 Apr 2019
[ 10:55 bhughes ] Original commit   Revision:499831
499831 UPDATING
499831 www/node/Makefile
499831 www/node/distinfo
499831 www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
499831 www/node/files/patch-deps_openssl_openssl__no__asm.gypi
499831 www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
499831 www/node/files/patch-deps_v8_src_libsampler_sampler.cc
499831 www/node/files/patch-node.gypi
499831 www/node/pkg-plist
www/node: Update 11.14.0 -> 12.0.0

Update to the latest major release of Node.js, which includes many
significant changes. Users are encouraced to read the release
announcement before upgrading.

https://nodejs.org/en/blog/release/v12.0.0/

Update minimum version requirements for dependencies. Regenerate patches
with `make makepatch`.

Sponsored by:	Miles AS
Tue, 23 Apr 2019
[ 08:27 mfechner ] Original commit   Revision:499731
499731 UPDATING
499731 www/gitlab-ce/Makefile
499731 www/gitlab-ce/distinfo
499731 www/gitlab-ce/files/gitlab.in
499731 www/gitlab-ce/files/patch-Gemfile
499731 www/gitlab-ce/files/patch-config_gitlab.yml.example
499731 www/gitlab-ce/files/patch-config_initializers_1__settings.rb
499731 www/gitlab-ce/pkg-message
499731 www/gitlab-ce/pkg-plist
Upgrade to 11.10.
For full log see:
https://about.gitlab.com/2019/04/22/gitlab-11-10-released/

WARNING, this release switches the path were the repositories are
stored back to the default git home dir. Make sure you read the
UPDATING 20190423 entry and follow the update maual very carefully!
Mon, 22 Apr 2019
[ 19:44 brnrd ] Original commit   Revision:499667
499667 UPDATING
499667 security/libressl/Makefile
499667 security/libressl/distinfo
499667 security/libressl/pkg-plist
499667 security/libressl/version.mk
security/libressl: Update to 2.9.1

 - Requires a rebuild of all dependent ports
Sun, 21 Apr 2019
[ 13:31 pi ] Original commit   Revision:499537
499537 UPDATING
499537 databases/cego/Makefile
499537 databases/cego/distinfo
499537 databases/cego/pkg-plist
499537 databases/cegobridge/Makefile
499537 databases/cegobridge/distinfo
499537 databases/p5-DBD-cego/Makefile
499537 databases/p5-DBD-cego/distinfo
499537 devel/lfcbase/Makefile
499537 devel/lfcbase/distinfo

(Only the first 10 of 12 ports in this commit are shown above. View all ports for this commit)
devel/lfcbase: update 1.11.9 -> 1.13.0
devel/lfcxml: update 1.2.6 -> 1.2.10
databases/cego: update 2.39.16 -> 2.44.1
databases/cegobridge: update 1.4.0 -> 1.5.0
databases/p5-DBD-cego: update 14.0 -> 1.5.0

- Warning: storage format has changed
  Export to xml format before upgrade and re-import after the upgrade
  See UPDATING
- recompile all applications linked to libcego
- Lots of changes, among them:
  o improved crash recovery
  o fixes to SQL expected behaviour
  o better CDATA handling
  o fixes primary key handling design issue
  o changes to serialisation for export/import, XML export/import is still
    possible

Submitted by:	Bjoern Lemke <lemke@lemke-it.com>
Changelog:	http://www.lemke-it.com/litexec?request=pubnews&user=&lang=en&numlog=1000
Fri, 19 Apr 2019
[ 23:20 bofh ] Original commit   Revision:499393
499393 UPDATING
UPDATING : Fix TYPOS with 20190419 entry

PR:		237395
Submitted by:	xxjack12xx@gmail.com
[ 22:48 mfechner ] Original commit   Revision:499391
499391 Mk/bsd.default-versions.mk
499391 UPDATING
Change default version of ruby from 2.4 to 2.5.

PR:             233901
Exp-Run:        antoine
Thu, 18 Apr 2019
[ 23:15 bofh ] Original commit   Revision:499318
499318 UPDATING
499318 emulators/qemu/Makefile
499318 emulators/qemu/distinfo
499318 emulators/qemu/files/patch-Makefile
499318 emulators/qemu/files/patch-configure
499318 emulators/qemu/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
499318 emulators/qemu/files/patch-hw_rdma_Makefile.objs
499318 emulators/qemu/files/patch-hw_rdma_vmw_pvrdma__cmd.c
499318 emulators/qemu/files/patch-include_net_net.h
499318 emulators/qemu/files/patch-include_qemu_atomic.h

(Only the first 10 of 14 ports in this commit are shown above. View all ports for this commit)
emulators/qemu: Update version 2.12.1=>3.0.1

- Remove GNS3 OPTION
- Update GTK2 OPTION to GTK3 to use updated requirements of gtk30 and sdl20
Wed, 10 Apr 2019
[ 13:13 rene ] Original commit   Revision:498562
498562 UPDATING
Belatedly add an entry to UPDATING for sysutils/password-store

PR:		224672
Reported by:	Adam Jimerson vendion@gmail.com
[ 05:47 antoine ] Original commit   Revision:498529
498529 Mk/bsd.default-versions.mk
498529 UPDATING
498529 devel/libpeas/Makefile
498529 mail/py-milter/Makefile
498529 math/py-matplotlib/Makefile
498529 textproc/py-enchant/Makefile
Switch default version of python to 3.6

PR:		234633
With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D18743
Fri, 29 Mar 2019
[ 20:13 jbeich ] Original commit   Revision:497194
497194 MOVED
497194 UPDATING
497194 mail/Makefile
497194 mail/thunderbird-i18n
497194 www/Makefile
497194 www/firefox-esr-i18n
497194 www/firefox-i18n
497194 www/seamonkey-i18n
gecko: drop -i18n ports

These haven't been QA'd for years, only blindly updated. After Firefox 57
language selection via extension was broken but Firefox 65 gained native UI.

PR:		221916
Thu, 28 Mar 2019
[ 19:59 tcberner ] Original commit   Revision:497056
497056 UPDATING
Add not about updating issues with www/qt5-webengine

Reported by:	Piotr Kubaj <pkubaj@anongoth.pl>
Sat, 16 Mar 2019
[ 12:24 vsevolod ] Original commit   Revision:495871
495871 UPDATING
495871 mail/rspamd-devel/Makefile
495871 mail/rspamd-devel/distinfo
495871 mail/rspamd-devel/files/rspamd.in
495871 mail/rspamd-devel/files/rspamd.newsyslog.conf.sample.in
495871 mail/rspamd-devel/files/rspamd_redirector.in
495871 mail/rspamd-devel/pkg-plist
495871 mail/rspamd/Makefile
495871 mail/rspamd/distinfo
495871 mail/rspamd/files/rspamd.in

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
- Update mail/rspamd to 1.9
- Remove obsoleted redirector start script
- Change user and group from nobody to Rspamd
- Add notes to UPDATING

PR:		236505
Submitted by:	Yasuhiro KIMURA <yasu at utahime.org>
Mon, 11 Mar 2019
[ 21:25 zeising ] Original commit   Revision:495395
495395 MOVED
495395 Mk/Uses/fonts.mk
495395 Mk/bsd.xorg.mk
495395 UPDATING
495395 arabic/ae_fonts_mono/Makefile
495395 arabic/ae_fonts_ttf/Makefile
495395 arabic/kacst_fonts/Makefile
495395 chinese/CJKUnifonts/Makefile
495395 chinese/CNS11643-font/Makefile
495395 chinese/arphicttf/Makefile

(Only the first 10 of 243 ports in this commit are shown above. View all ports for this commit)
x11-fonts/mkfontscale: Update to 1.2.0

Update x11-fonts/mkfontscale to 1.2.0
Remove x11-fonts/mkfontdir, which has been merged into mkfontscale.
Update dependencies and bump portrevisions.
Add an entry to UPDATING and MOVES

Changelog:
https://lists.x.org/archives/xorg/2019-March/059633.html

Thanks to Antoine for the exp-run!

PR:		236336 (exp-run)
Obtained from:	FreeBSD Graphics Team dev repo
		https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/mkfontscale
Sponsored by:	B3 Init
[ 16:53 rodrigo ] Original commit   Revision:495366
495366 UPDATING
Add a section in UPDATE after changes in www/igal2

PR:		202720
Sun, 3 Mar 2019
[ 22:33 sunpoet ] Original commit   Revision:494529
494529 UPDATING
Fix typo
[ 22:21 sunpoet ] Original commit   Revision:494526
494526 UPDATING
Document the x11-fonts/noto* changes
Sat, 2 Mar 2019
[ 08:23 pi ] Original commit   Revision:494373
494373 UPDATING
494373 sysutils/paladin/Makefile
494373 sysutils/paladin/distinfo
sysutils/paladin: update 1.1.1 -> 2.0.0

- An -f command line flag that allows specifying a config file
- A handle for the SIGINFO signal
- Args to the children are passed as an array (so that it's possible
  to pass an argument with a space in it)
- Fixes of some major bugs causing paladin to not correctly track
  the number of running children (so it wouldn't know when to exit),
  or not wait for children to exit before exiting itself after
  receiving SIGTERM.

PR:		236111
Submitted by:	rlwestlund@gmail.com
Approved by:	Randy Westlund <rwestlun@gmail.com>
Fri, 1 Mar 2019
[ 05:11 danfe ] Original commit   Revision:494236
494236 CHANGES
494236 README
494236 UPDATING
Remove superfluous linefeeds and spell Qt properly while here.
Wed, 27 Feb 2019
[ 07:14 meta ] Original commit   Revision:494028
494028 UPDATING
Document change forgotten in r494024 in UPDATING
Mon, 25 Feb 2019
[ 14:49 egypcio ] Original commit   Revision:493872
493872 UPDATING
493872 net-mgmt/mk-livestatus/Makefile
493872 net-mgmt/mk-livestatus/distinfo
493872 net-mgmt/mk-livestatus/files/pkg-message.in
net-mgmt/mk-livestatus: enable Nagios4 support by default

  - ../UPDATING

  add note regarding default options being changed.

  - Makefile

  adopt the port; update '1.2.8p22' to '1.2.8p24';
  enable Nagios 4.x as the default supported version;
  RUN_DEPENDS uses respective Nagios package as dependency;
  delete unnecessary ${RM} -r api/perl;
  new option now provides mk-livestatus' Perl API;
  clean USES variable; built just fine.

  - pkg-message

  update documentation's URL (linked the one with text in English);
  add clear note that Nagios' event broker support needs to be enabled.

Approved by:	rene (mentor)
Differential Revision:	https://reviews.freebsd.org/D18513
Sun, 24 Feb 2019
[ 15:22 tijl ] Original commit   Revision:493765
493765 UPDATING
493765 security/gnutls/Makefile
493765 security/gnutls/pkg-plist
- Let gnutls look for its configuration files in PREFIX/etc instead of /etc.
- Use --with-default-trust-store-file to set the location of the root
  certificates so configure doesn't have to autodetect this and the
  build dependency can be removed.
- Define TEST_TARGET.
- Remove DOCSDIR.  The files are also in PREFIX/share/info.
- Use p11-kit-trust as the default PKCS#11 trust store.

PR:		235703
Reported by:	mi
Wed, 20 Feb 2019
[ 15:13 mat ] Original commit   Revision:493424
493424 UPDATING
Expand a bit the "how do I change Perl5 major versions" entry.
Fri, 15 Feb 2019
[ 15:55 ashish ] Original commit   Revision:493003
493003 UPDATING
493003 net-im/ejabberd/Makefile
493003 net-im/ejabberd/files/patch-configure.ac
493003 net-im/ejabberd/files/patch-ejabberd-bug2744.diff
- Add a patch for the issue 2744
- Also revert a patch-configure.ac change from previous commits
- Document the change in UPDATING file
Sun, 3 Feb 2019
[ 09:07 pi ] Original commit   Revision:492028
492028 UPDATING
492028 archivers/urbackup-server/Makefile
492028 archivers/urbackup-server/distinfo
492028 archivers/urbackup-server/pkg-plist
archivers/urbackup-server: update 2.2.11 -> 2.3.7

- Changes some hardcoded paths from /etc/urbackup to ${PREFIX}/etc/urbackup
- Adds a note to UPDATING about the foregoing path change
- Uses sqlite3, lua, and lmdb from ports tree, rather than embedded
- Enables support for mounting of VHD files via fuse

PR:		235432
Submitted by:	freebsd@coombscloud.com (maintainer)
Relnotes:	https://www.urbackup.org/server_changelog.html
Thu, 24 Jan 2019
[ 23:11 girgen ] Original commit   Revision:491124
491124 UPDATING
Update fluentd to version 1.3.3

PR:             233939, 235179
Releasenotes:   https://github.com/fluent/fluentd/blob/master/CHANGELOG.md
Submitted by:	Artyom Davidov
Mon, 21 Jan 2019
[ 18:42 adamw ] Original commit   Revision:490879
490879 UPDATING
Amend the 20191113 entry to explain that geoipupdate must be used to
fetch the GeoIP 2 databases.

Reported by:	leres
Sun, 20 Jan 2019
[ 11:25 mandree ] Original commit   Revision:490780
490780 UPDATING
490780 mail/Makefile
490780 mail/fetchmail/Makefile
490780 mail/fetchmail/files/patch-SNI-Gitlab-9b8b634
490780 mail/fetchmail/files/patch-configure
490780 mail/fetchmail/files/patch-configure.ac
490780 mail/fetchmail/pkg-plist
490780 mail/fetchmailconf
490780 mail/fetchmailconf/Makefile
490780 mail/fetchmailconf/files/fetchmail.in

(Only the first 10 of 16 ports in this commit are shown above. View all ports for this commit)
mail/fetchmail depends overhaul, new fetchmailconf port

* Bring back SNI (server name indication) support for TLS connections,
  lost in 6.3.26_10 (PORTREVISION=10) as a regression over _9.
  Pointy hat: mandree@
* Drop the X11 option, remove the Python dependency, and create a new
  mail/fetchmailconf slave port/package that installs the fetchmailconf
  configurator. Note that the _DEPENDS of the ports reflects a technical
  dependence (fetchmailconf needs fetchmail), and we cannot keep an
  X11 option that depends on fetchmailconf, since that would create
  a circular dependency, which we must avoid.
* Patch configure instead of configure.ac with Cy's Kerberos fix, drop
  autoreconf from USES, and add a new configure check directly to set
  HAVE_DECL_SSLV3_CLIENT_METHOD to cover the various TLS providers
  (currently five, base, openssl, openssl111, libressl, libressl-devel)
* Add -Wl,--as-needed to LDFLAGS so as not to pull in unneeded .so
  libraries, for instance, libcom_err when compiling under GSSAPI_NONE.
* Bump PORTREVISION.

Very fruitful and nice collaboration with and
Approved by:	chalpin@cs.wisc.edu (maintainer)
Sat, 19 Jan 2019
[ 07:08 dinoex ] Original commit   Revision:490700
490700 UPDATING
490700 www/geolizer/Makefile
490700 www/webalizer/Makefile
490700 www/webalizer/files/patch-output.c
490700 www/webalizer/files/patch-webalizer.c
- fix option GEOIP to use GeoLite2-Country
Tue, 15 Jan 2019
[ 21:30 tcberner ] Original commit   Revision:490430
490430 UPDATING
490430 graphics/qgis/Makefile
490430 graphics/qgis/distinfo
490430 graphics/qgis/files/patch-cmake_FindPyQt5.py
490430 graphics/qgis/files/patch-debian_qgis.desktop
490430 graphics/qgis/files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py
490430 graphics/qgis/files/patch-python_plugins_processing_algs_saga_SagaUtils.py
490430 graphics/qgis/files/patch-src_app_main.cpp
490430 graphics/qgis/files/patch-src_core_qgsproject.cpp
490430 graphics/qgis/files/patch-src_plugins_grass_CMakeLists.txt

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
graphics/qgis: update to 3.4.3

QGIS 3.4 LTR, the first long-term release (LTR) of QGIS 3.

This is a major upgrade and users should consult the UPDATING entry
provided for further information on how to progress.

http://changelog.qgis.org/en/qgis/version/3.4-LTR/

PR:		233726
Submitted by:	Rainer Hurling <rhurlin@gwdg.de> (maintainer)
[ 00:52 jbeich ] Original commit   Revision:490329
490329 UPDATING
490329 x11-toolkits/wlroots/Makefile
490329 x11-toolkits/wlroots/distinfo
490329 x11-toolkits/wlroots/pkg-plist
490329 x11-wm/sway/Makefile
490329 x11-wm/sway/distinfo
490329 x11-wm/sway/pkg-plist
490329 x11/Makefile
490329 x11/swayidle
490329 x11/swayidle/Makefile

(Only the first 10 of 16 ports in this commit are shown above. View all ports for this commit)
x11-wm/sway: update to 1.0.b.2.189

The last beta is several months old, so use a snapshot to help users
evaluate the current state.

Changes:	https://github.com/swaywm/sway/compare/1.0-beta.2...2573606b
Changes:	https://github.com/swaywm/wlroots/compare/0.2...10a2c4ed
Sun, 13 Jan 2019
[ 20:58 adamw ] Original commit   Revision:490211
490211 UPDATING
490211 devel/pear-Horde_Nls/Makefile
490211 dns/bind9-devel/Makefile
490211 dns/bind911/Makefile
490211 dns/bind912/Makefile
490211 dns/bind913/Makefile
490211 dns/gdnsd/Makefile
490211 dns/gdnsd2/Makefile
490211 dns/powerdns/Makefile
490211 dns/powerdns/pkg-plist

(Only the first 10 of 59 ports in this commit are shown above. View all ports for this commit)
Remove GeoIP-related options. Where possible, replace GeoIP 1 defaults
with GeoIP 2.

Also, as suggested by zi, add an UPDATING note about this.

Number of commits found XX: 2438 (showing only 100 on this page)

[First Page]  «  1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11  »  [Last Page]

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
Security Policy
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
samba411Mar 28
samba412Mar 28
samba413Mar 28
linux-c7-nettleMar 27
nettleMar 27
opensslMar 26
spamassassinMar 24
giteaMar 23
giteaMar 21
dnsmasqMar 18
dnsmasq-develMar 18
gitlab-ceMar 18
minioMar 17
chromiumMar 16
libresslMar 16

12 vulnerabilities affecting 72 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2021-03-28 22:40:29


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 42809
Broken 73
Deprecated 286
Ignore 313
Forbidden 4
Restricted 137
No CDROM 71
Vulnerable 22
Expired 118
Set to expire 262
Interactive 0
new 24 hours 0
new 48 hours0
new 7 days0
new fortnight0
new month48

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2021 Dan Langille. All rights reserved.