notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Current status

The server has been repaired, with a new power supply, for $23. I am waiting for lower COVID rates before visiting the datacenter to return it.
non port: UPDATING
SVNWeb

Number of commits found XX: 2430 (showing only 100 on this page)

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11  »  [Last Page]

Mon, 22 Feb 2021
[ 17:25 blackend ] Original commit   Revision:566316
566316 UPDATING
Fix some typos.
Sat, 20 Feb 2021
[ 17:49 linimon ] Original commit   Revision:566176
566176 UPDATING
Wordsmithing.
[ 09:17 thierry ] Original commit   Revision:566151
566151 UPDATING
Add  a notice about the split of math/py-mathics into several ports.
Thu, 18 Feb 2021
[ 23:20 adridg ] Original commit   Revision:566008
566008 UPDATING
566008 games/mangband/Makefile
566008 games/mangband/distinfo
566008 games/mangband/files/patch-config.h
566008 games/mangband/files/patch-server_netserver.c
566008 games/mangband/files/patch-server_save.c
566008 games/mangband/files/patch-src_common_z-file.c
566008 games/mangband/files/patch-src_options.h
566008 games/mangband/files/patch-src_server_save.c
566008 games/mangband/files/patch-src_server_variable.c

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
Update games/mangband to latest upstream release

Unmark BROKEN, generate patches for the bits (duplicate symbols) that
broke the build, (these have been submitted upstream), massage messages
and such. Changing version **DOES** mean that you can't connect to
older servers, so include UPDATING to try to avoid people losing
games (killed by pkg upgrade is so much more disheartening than
killed by a Greater basilisk).

Reported by:	linimon
Fri, 12 Feb 2021
[ 10:41 rodrigo ] Original commit   Revision:565003
565003 UPDATING
565003 audio/spotifyd/Makefile
565003 audio/spotifyd/distinfo
565003 audio/spotifyd/files/patch-Cargo.toml
565003 audio/spotifyd/files/patch-src_utils.rs
565003 audio/spotifyd/files/spotifyd.conf
audio/spotifyd: upgrade to 0.3.0 and fix panic after rust update

Major changes:
    - Changed the config format from ini to TOML
      Make sure to update your config file accordingly[1].
    - Expose volume trough dbus
    - Add an option to disable dbus

Introduce two temporary patches to :
 - Fix panic reported in upstream bug system #719[2] - fixed in future
 - Fix compilation issue with FreeBSD (Merged after 0.3.0[3] release)

[1] https://github.com/Spotifyd/spotifyd/blob/master/docs/src/config/File.md
[2] https://github.com/Spotifyd/spotifyd/issues/719
[3]
https://github.com/Spotifyd/spotifyd/pull/796/commits/a352eab53eef0ecafe1ddb07a43ff2b3ab54f123

PR:		251968
Submitted by:	<nick.rozhkov@gmail.com>
Tue, 9 Feb 2021
[ 11:18 tcberner ] Original commit   Revision:564780
564780 UPDATING
UPDATING: document graphics/opencv-core removal

PR:		253116
Mon, 8 Feb 2021
[ 17:01 crees ] Original commit   Revision:564727
564727 UPDATING
564727 mail/mailscanner/Makefile
564727 mail/mailscanner/distinfo
564727 mail/mailscanner/files/CHANGES.port
564727 mail/mailscanner/files/mailscanner.in
564727 mail/mailscanner/files/mta.in
564727 mail/mailscanner/files/pkg-message.in
564727 mail/mailscanner/pkg-plist
Update to 5.4.3-3

Several changes in virus detection code

Output to stdout/stderr when running in foreground mode

... and much more:

https://raw.githubusercontent.com/MailScanner/v5/3c2329/changelog
Thu, 4 Feb 2021
[ 23:01 osa ] Original commit   Revision:564068
564068 UPDATING
564068 www/unit/Makefile
Change the default location for NGINX Unit's state directory has changed.
It was moved from /usr/local/libexec/unit to /var/db/unit in order to
avoid write operations on /usr/local filesystem.

Bump PORTREVISION.
Sun, 24 Jan 2021
[ 12:20 kai ] Original commit   Revision:562467
562467 UPDATING
562467 net-mgmt/netbox/Makefile
562467 net-mgmt/netbox/distinfo
562467 net-mgmt/netbox/files/pkg-message.in
562467 net-mgmt/netbox/pkg-plist
net-mgmt/netbox: Update to 2.10.3

* Prune obsolete update instructions/notes for NetBox releases prior 2.7.

Notable changes since 2.9.11:

It contains many bugfixes/enhancements and the following new features:

* Route Targets
* REST API bulk deletion
* REST API bulk update
* Reimplementation of custom fields
* Improved cable trace performance

https://github.com/netbox-community/netbox/blob/v2.10.3/docs/release-notes/version-2.10.md
Thu, 14 Jan 2021
[ 16:49 mikael ] Original commit   Revision:561572
561572 UPDATING
561572 net-im/matterircd/Makefile
561572 net-im/matterircd/distinfo
561572 net-im/matterircd/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go
net-im/matterircd: Update to 0.22.0

PR:		252668
Submitted by:	norrland@nullbyte.se
Wed, 13 Jan 2021
[ 16:13 osa ] Original commit   Revision:561486
561486 UPDATING
561486 databases/Makefile
561486 databases/p5-AnyEvent-Redis/Makefile
561486 databases/p5-Redis-Fast/Makefile
561486 databases/py-redis/Makefile
561486 databases/py-redis2/Makefile
561486 databases/py-txredisapi/Makefile
561486 databases/redis-devel/Makefile
561486 databases/redis/Makefile
561486 databases/redis/distinfo

(Only the first 10 of 31 ports in this commit are shown above. View all ports for this commit)
Update databases/redis to the recent stable version 6.0.10.
Update CONFLICTS for:
o) databases/redis4
o) databases/redis5
o) databases/redis
o) databases/redis-devel

Connect databases/redis5 to the build.

Bump PORTREVISIONs for dependant ports.
Sun, 10 Jan 2021
[ 12:44 blackend ] Original commit   Revision:561063
561063 UPDATING
Typos fixing.
Sat, 9 Jan 2021
[ 21:16 glewis ] Original commit   Revision:560893
560893 UPDATING
Fix a typo
Wed, 6 Jan 2021
[ 14:58 pi ] Original commit   Revision:560527
560527 UPDATING
560527 mail/dovecot-fts-xapian/Makefile
560527 mail/dovecot-pigeonhole/Makefile
560527 mail/dovecot-pigeonhole/distinfo
560527 mail/dovecot/Makefile
560527 mail/dovecot/distinfo
560527 mail/dovecot/pkg-plist
mail/dovecot: update 2.3.11.3 -> 2.3.13, fix CVE in non-default config
mail/dovecot-pigeonhole: update 0.5.11 -> 0.5.13

- please note: option VPOPMAIl was removed from upstream

PR:		252415
Submitted by:	Evilham <contact@evilham.com>
Reviewed by:	fluffy
Approved by:	ler (maintainer)
MFH:		2021Q1
Relnotes:	https://dovecot.org/pipermail/dovecot-news/2021-January/000448.html
		https://dovecot.org/pipermail/dovecot-news/2021-January/000449.html
Security:	CVE-2020-24386, CVE-2020-25275
[ 13:32 dch ] Original commit   Revision:560510
560510 UPDATING
560510 sysutils/graylog/Makefile
560510 sysutils/graylog/distinfo
560510 sysutils/graylog/files/pkg-message.in
560510 sysutils/graylog/pkg-plist
sysutils/graylog: update to 4.0 and change license to SSPL

graylog 4.0 and higher now use a new license, the SSPL. For more
details, see https://www.graylog.org/post/graylog-v4-0-licensing-sspl

Submitted by:	Charles Goncalves <charles@freebsdbrasil.com.br>
Reviewed by:	dch (maintainer)
Sponsored by:	SkunkWerks, GmbH
Differential Revision:	https://reviews.freebsd.org/D27253
Sat, 2 Jan 2021
[ 16:36 madpilot ] Original commit   Revision:559953
559953 MOVED
559953 Mk/Uses/xfce.mk
559953 UPDATING
559953 archivers/thunar-archive-plugin/Makefile
559953 audio/thunar-media-tags-plugin/Makefile
559953 audio/xfce4-pulseaudio-plugin/Makefile
559953 deskutils/orage/Makefile
559953 deskutils/orage/pkg-descr
559953 deskutils/orage/pkg-plist
559953 deskutils/xfce4-generic-slider/Makefile

(Only the first 10 of 117 ports in this commit are shown above. View all ports for this commit)
Welcome XFCE 4.16 to the FreeBSD ports tree!

Upstream announce: https://xfce.org/about/news/?post=1608595200

This XFCE release dropped support for GTK2 plugins and also dropped
GTK2 from all components.

WARNING: please check UPDATING before upgrading your packages. In
case of problems also read the libexo pkg-message.

Due to this some panel plugins and libraries will be removed since
they cannot compile anymore:

- print/xfce4-print
- x11/xfce4-quicklauncher-plugin
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Mon, 28 Dec 2020
[ 15:35 amdmi3 ] Original commit   Revision:559491
559491 UPDATING
Cleanup whitespace
[ 14:32 jbeich ] Original commit   Revision:559480
559480 MOVED
559480 UPDATING
559480 www/Makefile
559480 www/flexget
559480 www/flexget/Makefile
559480 www/flexget/pkg-descr
559480 www/py-flexget
www/py-flexget: rename to flexget and clean up

- Update COMMENT and pkg-descr from upstream
- Drop py- suffix because standalone and only for default python
- Drop out-of-date "Created by": everything changed since r321564
- Drop PORTEPOCH as package name changed
- Sort variables
Sat, 19 Dec 2020
[ 07:57 kai ] Original commit   Revision:558439
558439 UPDATING
558439 www/qt5-webengine/Makefile
558439 www/qt5-webengine/distinfo
558439 www/qt5-webengine/files/patch-clang
558439 www/qt5-webengine/files/patch-configure.pri
558439 www/qt5-webengine/files/patch-mkspecs_features_functions.prf
558439 www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
558439 www/qt5-webengine/files/patch-src_3rdparty_chromium_base_BUILD.gn
558439 www/qt5-webengine/files/patch-src_3rdparty_chromium_base_debug_elf__reader.cc
558439 www/qt5-webengine/files/patch-src_3rdparty_chromium_base_debug_proc__maps__linux.cc

(Only the first 10 of 156 ports in this commit are shown above. View all ports for this commit)
www/qt5-webengine: Update to 5.15.2

* Under the hood runs Chromium 83.0.4103.122 with security fixes up to
  version 86.0.4240.183 and patches were taken from r540991 of www/chromium.

* Also adjust some patches to avoid hardcoding of ${LOCALBASE} and remove a
  redundant blank line.

Changelog:

* [QTBUG-84632] Warn about QtWebengineProcess launching from network share
                on Windows.
* [QTBUG-85363] Handle non-ASCII names for PulseAudio
* [QTBUG-85494] Fix regression crash when not handling
                QQuickWebEngineNewViewRequest
* [QTBUG-85817] Fix crashes on resize
* [QTBUG-86672] Fix remapped menu key being mapped back to menu key
* [QTBUG-86945] Fix crash when opening a PDF in debug build on windows.
* [QTBUG-87129] Mention node.js build-time dependency
* The QtWebEngineProcess now has a version number
* The old compositor has been removed and can no longer be restored using
  command line argument.

Approved by:	tcberner (kde)
Differential Revision:	https://reviews.freebsd.org/D27587
Tue, 1 Dec 2020
[ 19:12 rene ] Original commit   Revision:556784
556784 MOVED
556784 Mk/Scripts/qa.sh
556784 Mk/Uses/jpeg.mk
556784 UPDATING
556784 graphics/Makefile
556784 graphics/jpeg
Remove graphics/jpeg which has expired in favor of graphics/jpeg-turbo

Update qa checks and add a note to UPDATING to help users migrate.
Differential Revision:	https://reviews.freebsd.org/D27425
Sat, 28 Nov 2020
[ 19:30 pi ] Original commit   Revision:556519
556519 UPDATING
UPDATING: add note about databases/cego 2.45.x -> 2.46.x
[ 14:54 mfechner ] Original commit   Revision:556492
556492 Mk/bsd.default-versions.mk
556492 UPDATING
Switch default version of Ruby from 2.6 to 2.7.

For detailed list of changes, please check the Ruby website:
https://www.ruby-lang.org/en/news/2019/12/25/ruby-2-7-0-released/
https://www.ruby-lang.org/en/news/2020/03/31/ruby-2-7-1-released/
https://www.ruby-lang.org/en/news/2020/10/02/ruby-2-7-2-released/

How to upgrade is described in UPDATING entry 20201128.

PR:		244787
Submitted by:	meta@
Exp-Run:	https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=244787
Thanks to:	antoine, meta
Thu, 12 Nov 2020
[ 16:45 rhurlin ] Original commit   Revision:554971
554971 UPDATING
UPDATING: New entry for net-mgmt/pushgateway data format migration

Approved by:	tcberner (mentor), 0mp
Differential Revision:	https://reviews.freebsd.org/D27192
Tue, 10 Nov 2020
[ 09:11 kai ] Original commit   Revision:554823
554823 UPDATING
554823 net-mgmt/netbox/Makefile
554823 net-mgmt/netbox/distinfo
554823 net-mgmt/netbox/files/pkg-message.in
554823 net-mgmt/netbox/pkg-plist
net-mgmt/netbox: Update to 2.9.8

* Limit the version ranges of the required Python packages and use very
  narrow ranges for those ones, which often cause regressions.

  That is because upstream already uses fixed Python package dependencies
  for a while and had relaxed them for a short period of time.

  However, because it led to regressions when some Python packages were
  updated during that time, upstream has been using fixed package
  dependencies again since then.

Changelog since 2.7.12:

It contains many bugfixes/enhancements and the following new features:
(Only the first 15 lines of the commit message are shown above View all of this commit message)
Fri, 6 Nov 2020
[ 16:53 dvl ] Original commit   Revision:554304
554304 UPDATING
554304 sysutils/samdruckerclientshell/Makefile
554304 sysutils/samdruckerclientshell/distinfo
554304 www/samdruckerserver/Makefile
554304 www/samdruckerserver/distinfo
554304 www/samdruckerserver/pkg-plist
Update to 0.2.4

re https://github.com/dlangille/SamDrucker/releases/tag/0.2.4

See UPDATING for database schema changes
Thu, 5 Nov 2020
[ 09:28 lwhsu ] Original commit   Revision:554125
554125 UPDATING
Fix UPDATING 20200210 net-im/prosody entry

PR:		245053
Submitted by:	Thomas Morper <thomas@beingboiled.info>
Fri, 30 Oct 2020
[ 20:36 mandree ] Original commit   Revision:553713
553713 UPDATING
553713 security/openvpn/Makefile
553713 security/openvpn/distinfo
553713 security/openvpn/files/extra-tunnelblick-openvpn_xorpatch
553713 security/openvpn/files/patch-configure
553713 security/openvpn/files/patch-git-098edbb1f5a2e1360fd6a4ae0642b63bec12e992
553713 security/openvpn/files/patch-git-38b46e6bf65489c2c5d75da1c02a3a1c33e6da88
553713 security/openvpn/files/patch-git-b89e48b015e581a4a0f5c306e2ab20da34c862ea
553713 security/openvpn/files/patch-git-cab48ad43eaba51c54fa23e55b0b2eb436dd921f
553713 security/openvpn/files/patch-git-fc0297143494e0a0f08564d90dbb210669d0abf5

(Only the first 10 of 12 ports in this commit are shown above. View all ports for this commit)
Update security/openvpn 2.5. For 2.3 peers, update your configuration,

...see ports/UPDATING or the
ChangeLog:
https://github.com/OpenVPN/openvpn/blob/release/2.5/Changes.rst#overview-of-changes-in-25

Avoid LibreSSL (IGNORE_SSL).
INSTALL_DATA -> INSTALL_MAN for documentation.
Rearrange Makefile according to portclippy.
Thu, 29 Oct 2020
[ 21:32 bhughes ] Original commit   Revision:553645
553645 UPDATING
553645 www/node/Makefile
553645 www/node/distinfo
553645 www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
553645 www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
553645 www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc
553645 www/node/files/patch-deps_v8_src_execution_simulator.h
553645 www/node/files/patch-deps_v8_src_libsampler_sampler.cc
553645 www/node/files/patch-node.gypi
553645 www/node/pkg-plist
www/node: Update 14.14.0 -> 15.0.0

Update to the latest major release of Node.js, which includes many
significant changes. Users are encouraged to read the release notes
before upgrading.

https://nodejs.org/en/blog/release/v15.0.0/

While here, refresh existing patches with `make makepatch`, removing
some powerpc* related patches that have been adopted/reworked upstream
in V8.

Remove the dependency on dns/c-ares and use the bundled version
instead, since Node.js has adopted a change to c-ares that has not yet
been released. The dependency will be re-added once dns/c-ares has
been updated to a release that contains support for CAA DNS records.

An UPDATING entry has also been added to include a notice about this
major version upgrade, and steps users can take to continue using the
v14.x line, which is now LTS.

Sponsored by:	Miles AS
Mon, 26 Oct 2020
[ 01:30 bofh ] Original commit   Revision:553312
553312 UPDATING
553312 emulators/qemu/Makefile
553312 emulators/qemu/distinfo
553312 emulators/qemu/files/patch-Makefile
553312 emulators/qemu/files/patch-configure
553312 emulators/qemu/files/patch-include_qemu_atomic.h
553312 emulators/qemu/files/patch-qemu-doc.texi
553312 emulators/qemu/pkg-plist
emulators/qemu: Update version 4.2.1=>5.0.1

- Add OPTION DEBUG
Wed, 21 Oct 2020
[ 16:18 osa ] Original commit   Revision:552870
552870 MOVED
552870 UPDATING
552870 www/py-unit
Remove renamed port.
Mon, 19 Oct 2020
[ 16:19 fernape ] Original commit   Revision:552748
552748 UPDATING
552748 sysutils/rundeck3/Makefile
552748 sysutils/rundeck3/distinfo
sysutils/rundeck3: Update to 3.3.4

ChangeLog: https://docs.rundeck.com/docs/history/3_3_x/version-3.3.4.html

PR:	250446
Submitted by:	daniel.tihanyi@tetragir.com (maintainer)
Mon, 12 Oct 2020
[ 14:24 bapt ] Original commit   Revision:552131
552131 UPDATING
Document libsoup-gnome merge into libsoup
[ 08:30 manu ] Original commit   Revision:552109
552109 UPDATING
552109 devel/libclc/Makefile
552109 graphics/Makefile
552109 graphics/libosmesa/Makefile
552109 graphics/mesa-dri/Makefile
552109 graphics/mesa-dri/Makefile.common
552109 graphics/mesa-dri/distinfo
552109 graphics/mesa-dri/files/extra-src_gallium_auxiliary_meson.build
552109 graphics/mesa-dri/files/extra-src_gallium_auxiliary_vl_vl__stubs.c
552109 graphics/mesa-dri/files/extra-src_mesa_drivers_dri_i965_intel__screen.c

(Only the first 10 of 58 ports in this commit are shown above. View all ports for this commit)
graphics/mesa*: Update to 20.2

Update to 20.2
Move graphics/libxatracker to graphics/mesa-gallium-xa
Remove VAAPI and VDPAU options in mesa-libs in favor of
two new ports : mesa-gallium-va and mesa-gallium-vdpau
Bump needed llvm to llvm10
Change a lot of meson option from false to disabled as it's
deprecated.
Remove the drm and surfaceless platform from mesa* as it's always
enabled now.
Add zstd option, used for shader cache.

Reviewed by:	x11 (zeising@)
Differential Revision:	https://reviews.freebsd.org/D26682
Tue, 6 Oct 2020
[ 09:17 0mp ] Original commit   Revision:551564
551564 GIDs
551564 UIDs
551564 UPDATING
551564 sysutils/tenshi/Makefile
551564 sysutils/tenshi/distinfo
sysutils/tenshi: Update to 0.17

- Assume maintainership
- Drop coreutils from dependencies; tenshi works fine now with FreeBSD tail
- Get tarballs from to GitHub; this is where upstream moved
- Install configuration files in upstream default location
Mon, 5 Oct 2020
[ 19:09 mandree ] Original commit   Revision:551537
551537 UPDATING
551537 mail/fetchmail/Makefile
551537 mail/fetchmail/files/fetchmail.in
551537 mail/fetchmailconf/Makefile
mail/fetchmail: avoid rc.conf overriding daemon interval, many other fixes

Authors: CH = Corey Halpin, MA = Matthias Andree

- fetchmail's rc script now queries the daemon interval from the
  configuration, and falls back to the rc.conf value if given. [CH]
- Similarly, the logging facility will be taken from the configuration [MA]
- Add documentation to the rcfile's header comments. [MA]
- Drop support for fetchmail_home_prefix in rc.conf, and query the
  respective users' home directories with getent instead. [MA]
- In the rc scripts, redirect input from /dev/null so it will not ask
  for passwords. [MA]
- Add support for the typical 12.1 rc.conf ${name}_... keywords. [MA]
- Make script execution easier to follow by simplifying if...else logic. [CH]
- Fix rcscript's exit code to be 1 if one of the per-user calls fails. [CH]
- Add relevant notes to UPDATING. [MA]

PR:		249860
Submitted by:	Corey Halpin (maintainer)
Reported by:	Chris James (on fetchmail-users mailing list)
Approved by:	Corey Halpin (maintainer)
Fri, 2 Oct 2020
[ 19:18 0mp ] Original commit   Revision:551226
551226 UPDATING
551226 sysutils/modules/Makefile
551226 sysutils/modules/distinfo
551226 sysutils/modules/files/patch-Makefile.in
551226 sysutils/modules/files/patch-cmdModule.c
551226 sysutils/modules/files/patch-configure
551226 sysutils/modules/files/patch-doc__Makefile
551226 sysutils/modules/files/patch-doc__Makefile.in
551226 sysutils/modules/files/patch-doc__module.1.in
551226 sysutils/modules/files/patch-doc__modulefile.5.in

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
Update to 4.6

The most important changes are described in the MIGRATING document:
- https://modules.readthedocs.io/en/v4.6.0/MIGRATING.html

Release notes:
- https://modules.readthedocs.io/en/v4.6.0/NEWS.html
-
https://timeline.noticeable.io/cbzeG7wTvAIqj21zbUmx/posts/modules-4-6-0-released

PR:		249978
Submitted by:	Matthieu Volat <mazhe@alkumuna.eu>
Tue, 29 Sep 2020
[ 17:04 cy ] Original commit   Revision:550534
550534 UPDATING
550534 sysutils/syslog-ng327/Makefile
550534 sysutils/syslog-ng327/files/pkg-message.in
550534 sysutils/syslog-ng327/files/syslog-ng.in
550534 sysutils/syslog-ng328/Makefile
550534 sysutils/syslog-ng328/files/pkg-message.in
550534 sysutils/syslog-ng328/files/syslog-ng.in
550534 sysutils/syslog-ng329/Makefile
550534 sysutils/syslog-ng329/files/pkg-message.in
550534 sysutils/syslog-ng329/files/syslog-ng.in
Rename rc.conf variables syslog_ng_config and syslog_ng_pid to
syslog_ng_flags and syslog_ng_pidfile respecively, making them
consistent with the rest of the ports tree.

PR:		249984
Submitted by:	Boris Korzun <drtr0jan@yandex.ru>
Reviewed by:	Peter Czanik (syslog-ng upstream)
Sat, 26 Sep 2020
[ 09:44 rhurlin ] Original commit   Revision:550146
550146 UPDATING
UPDATING: Correct the dirname database/* to databases/*

In UPDATING, all sections which contain "database/..." instead of
"databases/..." in the 'AFFECTS:' line, utilities like 'pkg updating' can't
automatically display those sections.

The postgresql sections in particular have information that would be useful for
casual use of "pkg updating". One work-around, of course, is to use "pkg
updating database/postgresql"

While here, also correct some more occurrences.

PR:		249881
Submitted by:	rhurlin
Reported by:	Keith White <kwhite@site.uottawa.ca>
Approved by:	tcberner (mentor)
Differential Revision:	https://reviews.freebsd.org/D26557
Thu, 24 Sep 2020
[ 22:52 dbaio ] Original commit   Revision:549970
549970 UPDATING
Typo
[ 22:20 zi ] Original commit   Revision:549967
549967 UPDATING
549967 net/freeradius3/Makefile
549967 net/freeradius3/pkg-plist
- Convert PYTHON support to use python 3.x
- Add note to UPDATING

PR:		249743
Submitted by:	Steve Wills <swills@FreeBSD.org>
Tue, 22 Sep 2020
[ 19:57 kbowling ] Original commit   Revision:549629
549629 UPDATING
Add an UPDATING entry for PostgreSQL default version change to 12

PR:		248657
Reported by:	tz
Sponsored by:	BBOX.io
Fri, 18 Sep 2020
[ 10:02 cmt ] Original commit   Revision:548882
548882 UPDATING
548882 mail/thunderbird/Makefile
548882 mail/thunderbird/distinfo
548882 mail/thunderbird/files/patch-browser-app-nsBrowserApp.cpp
548882 mail/thunderbird/files/patch-bug1269654_comment5
548882 mail/thunderbird/files/patch-bug1288587
548882 mail/thunderbird/files/patch-bug1504834_comment10
548882 mail/thunderbird/files/patch-bug1504834_comment5
548882 mail/thunderbird/files/patch-bug1504834_comment9
548882 mail/thunderbird/files/patch-bug1550891

(Only the first 10 of 28 ports in this commit are shown above. View all ports for this commit)
update mail/thunderbird to 78.2.2

See https://support.mozilla.org/en-US/kb/new-thunderbird-78 for major
changes in Thunderbird 78, the release announcement in
https://blog.thunderbird.net/2020/07/whats-new-in-thunderbird-78/ and
https://blog.thunderbird.net/2020/09/openpgp-in-thunderbird-78/ info
for OpenPGP users. Also check UPDATING 20200918.
Current release notes are in
https://www.thunderbird.net/en-US/thunderbird/78.2.2/releasenotes/

PR:		249346
Submitted by:	jbeich
Sun, 13 Sep 2020
[ 22:03 tz ] Original commit   Revision:548578
548578 Mk/bsd.default-versions.mk
548578 UPDATING
Switch default version of PHP from 7.2 to 7.4.

7.2 does not receive any bugfixes anymore. Also the security fixes will
end at 2020-11-30.
Since PHP 7.3 will only receive bugfixes for the next 2 month, we
switch directly to 7.4

PR:		248074
Sponsored by:	Bounce Experts
Wed, 12 Aug 2020
[ 18:30 jrm ] Original commit   Revision:544763
544763 Mk/Uses/emacs.mk
544763 UPDATING
544763 audio/emms/Makefile
544763 cad/dinotrace/Makefile
544763 cad/verilog-mode.el/Makefile
544763 databases/bbdb/Makefile
544763 databases/gnats4/Makefile
544763 deskutils/howm/Makefile
544763 devel/cask/Makefile
544763 devel/clojure-cider/Makefile

(Only the first 10 of 86 ports in this commit are shown above. View all ports for this commit)
editors/emacs: Update to version 27.1

Please refer to the 20200811 UPDATING entry when upgrading
dependent (*-emacs26-*) ports.

Port changes:

- depend on math/gmp
- match upstream by turning CAIRO, HARFBUZZ, and JSON options and on and
  turning MAGICK off by default
- remove OPENMP check for graphics/ImageMagick as the openmp is now
  included in base
- update EMACS_VER in Mk/Uses/emacs.mk
- bump USES=emacs ports or remove BROKEN for net-im/jabber.el and
  deskutils/howm, which now build

Submitted by:	HIROSE Yuuji <yuuji@gentei.org> (canna patch)
Reviewed by:	ashish
Differential Revision:	https://reviews.freebsd.org/D23966
Mon, 3 Aug 2020
[ 12:56 mat ] Original commit   Revision:544063
544063 Mk/bsd.default-versions.mk
544063 UPDATING
Update the default Perl version to 5.32.

PR:		247826
Submitted by:	mat
Exp-run by:	antoine
Sun, 26 Jul 2020
[ 17:48 dvl ] Original commit   Revision:543487
543487 UPDATING
543487 net-mgmt/librenms/Makefile
543487 net-mgmt/librenms/files/librenms.in
543487 net-mgmt/librenms/files/patch-.env.example
543487 net-mgmt/librenms/files/pkg-message.in
Fix double logging

HEADS UP: See UPDATING for changes affecting your upgrade.
          New installs not affected.

This patch adds a new rc_variable: librenms_daemonflags

The -T option is gone as that will force a log to syslog, doubling up on log
entries.

A new APP_LOG setting has been added to the .env file. Please update and
move your logs.  See UPDATING.

PR:		246598
Submitted by:	Dries Michiels <driesm.michiels@gmail.com>
Fri, 24 Jul 2020
[ 06:28 ehaupt ] Original commit   Revision:543004
543004 UPDATING
Amend bash entry from 20200716 with a solution for a know problem that occurs
after an incomplete base update.

PR:	248209 (motivated by)
Mon, 20 Jul 2020
[ 21:35 dvl ] Original commit   Revision:542675
542675 UPDATING
542675 net-mgmt/librenms/Makefile
542675 net-mgmt/librenms/distinfo
542675 net-mgmt/librenms/files/patch-LibreNMS_Util_Version.php
542675 net-mgmt/librenms/files/patch-LibreNMS_Validations_Php.php
542675 net-mgmt/librenms/files/patch-LibreNMS_Validations_Programs.php
542675 net-mgmt/librenms/files/patch-LibreNMS_Validations_Python.php
542675 net-mgmt/librenms/files/patch-LibreNMS_Validations_User.php
542675 net-mgmt/librenms/files/patch-config.php.default
542675 net-mgmt/librenms/files/patch-html_install.php

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
Update to 1.65.1

This upgrade disables polling via cronjob.
You must now use the Dispatcher.  See UPDATING
Sat, 18 Jul 2020
[ 19:42 bofh ] Original commit   Revision:542523
542523 UPDATING
542523 emulators/qemu/Makefile
542523 emulators/qemu/distinfo
542523 emulators/qemu/files/patch-Makefile
542523 emulators/qemu/files/patch-configure
542523 emulators/qemu/files/patch-include_net_net.h
542523 emulators/qemu/files/patch-include_qemu_atomic.h
542523 emulators/qemu/files/patch-qemu-doc.texi
542523 emulators/qemu/files/pcap-patch-net_net.c
542523 emulators/qemu/files/pcap-patch-qapi_net.json

(Only the first 10 of 11 ports in this commit are shown above. View all ports for this commit)
emulators/qemu: Update version 4.1.1=>4.2.1

- Add OPTION CAPSTONE [1]

PR:		247870 [1]
Reported by:	amdmi3 [1]
Thu, 16 Jul 2020
[ 17:14 ehaupt ] Original commit   Revision:542373
542373 UPDATING
542373 shells/bash/Makefile
Cleanly decouple bash from base by reading `profile` from $LOCALBASE/etc/
instead of from /etc.

Document this change in UPDATING and provide a migration strategy.

PR:		247934 (based on)
Submitted by:	Michael Osipov <michael.osipov@siemens.com>
Mon, 13 Jul 2020
[ 13:32 tz ] Original commit   Revision:542132
542132 UPDATING
542132 lang/php72/Makefile.ext
542132 lang/php73/Makefile.ext
542132 lang/php74/Makefile.ext
542132 mail/php72-imap/Makefile
542132 mail/php73-imap/Makefile
542132 mail/php74-imap/Makefile
mail/php7[2-4]-imap: change client from cclient to panda-cclient

There are some reports about PHP crashes, when using php-imap
(especially with OpenSSL and TSL 1.3). All this problems went away,
when using the panda-cclient instead of the old cclient.

Therefore we make the panda-cclient the new default,
but still allow cclient in order to allow backwards compatibility.

Special thanks to bofh for figuring out the complex details and
the solution!

Special thanks to Jason for being patience and
helpful about so many months!

Reported by:	Jason de Cordoba <jason@aventia.pw>
Reviewed by:	bofh
Sponsored by:	Bounce Experts
Tue, 16 Jun 2020
[ 09:28 gahr ] Original commit   Revision:539336
539336 UPDATING
UPDATING: document www/baikal's configuration changes
Sat, 13 Jun 2020
[ 15:27 linimon ] Original commit   Revision:538680
538680 UPDATING
Fix obvious typo.
[ 15:11 fluffy ] Original commit   Revision:538677
538677 UPDATING
- Note changed OPTIONS and defaults for editors/libreoffice
Fri, 12 Jun 2020
[ 04:17 bhughes ] Original commit   Revision:538561
538561 UPDATING
UPDATING: add note about www/node upgrade to 14.0.0

Sponsored by:	Miles AS
Tue, 2 Jun 2020
[ 20:51 decke ] Original commit   Revision:537581
537581 UPDATING
537581 www/radicale/Makefile
537581 www/radicale/distinfo
537581 www/radicale/files/radicale.in
537581 www/radicale/pkg-descr
537581 www/radicale/pkg-message
537581 www/radicale/pkg-plist
www/radicale:
- Update to 2.1.12
- Please follow UPDATING instructions because you need to export the
storage with radicale 1.1.6 before updating
[ 11:23 krion ] Original commit   Revision:537537
537537 MOVED
537537 UPDATING
537537 sysutils/Makefile
537537 sysutils/py-salt-2019
537537 sysutils/py-salt-2019/Makefile
537537 sysutils/py-salt/Makefile
537537 sysutils/py-salt/distinfo
537537 sysutils/py-salt/files/patch-requirements_base.txt
Update py-salt to version 3000 and repo copy py-salt to py-salt-2019.
We decided to run both versions for a while until 2019 is EOL and give people
the possibility to run newest 3000 version.

Approved by:	maintainer
Sun, 31 May 2020
[ 13:49 dbaio ] Original commit   Revision:537162
537162 GIDs
537162 UIDs
537162 UPDATING
537162 mail/Makefile
537162 mail/postfix-policyd-spf-python/Makefile
537162 mail/py-spf-engine
537162 mail/py-spf-engine/Makefile
537162 mail/py-spf-engine/distinfo
537162 mail/py-spf-engine/files/patch-setup.py
537162 mail/py-spf-engine/files/patch-spf__engine_milter__spf.py

(Only the first 10 of 13 ports in this commit are shown above. View all ports for this commit)
Add mail/py-spf-engine, Deprecate mail/postfix-policyd-spf-python

Give time to users to change their env

The new port is the successor, it supports milter feature and its
config file is in another path.

PR:		244424
Submitted by:	Yasuhiro KIMURA <yasu@utahime.org> (maintainer)
Tue, 26 May 2020
[ 10:13 brnrd ] Original commit   Revision:536604
536604 UPDATING
UPDATING: Notify users about changes in MariaDB 10.4 config

MFH:		2020Q2
Mon, 25 May 2020
[ 17:06 zeising ] Original commit   Revision:536482
536482 UPDATING
UPDATING: fix typo in converters/libiconv title.

PR:		240954
Reported by:	Yuichiro NAITO
Mon, 18 May 2020
[ 18:31 zeising ] Original commit   Revision:535769
535769 UPDATING
535769 converters/libiconv/Makefile
535769 converters/libiconv/distinfo
535769 converters/libiconv/files/patch-include-iconv.h.in
535769 converters/libiconv/files/patch-libcharset__lib__config.charset
535769 converters/libiconv/files/patch-libcharset_lib_localcharset.c
535769 converters/libiconv/files/patch-src__Makefile.in
535769 converters/libiconv/pkg-plist
converters/libiconv: Update to 1.16

Update converters/libiconv to 1.16.
This update removes the extra patches for CP932 and EUCJP-MS, as they are
not compatible with this release.
Add an UPDATING entry for this change.
ABI/API stable, no need to bump dependent ports:
https://abi-laboratory.pro/index.php?view=timeline&l=libiconv

PR:		240954
Submitted by:	Yuichiro NAITO
Exp-run by:	antoine
Approved by:	maintainer timeout (gnome@)
Sun, 17 May 2020
[ 08:21 arrowd ] Original commit   Revision:535524
535524 UIDs
535524 UPDATING
535524 x11/sddm/Makefile
535524 x11/sddm/pkg-message
x11/sddm: Switch SDDM user's HOME directory from /usr/local/etc/sddm/home to
/var/lib/sddm, as sddm(5) man page requests.

PR:		244756
Reviewed by:	tcberner, adridg
Fri, 15 May 2020
[ 18:07 grembo ] Original commit   Revision:535310
535310 UPDATING
535310 devel/arcanist-lib/Makefile
535310 devel/arcanist-lib/distinfo
535310 devel/arcanist-lib/files/patch-src-toolset-workflow-ArcanistVersionWorkflow.php
535310 devel/arcanist-lib/files/patch-src-workflow-ArcanistVersionWorkflow.php
535310 devel/arcanist-lib/pkg-plist
535310 devel/libphutil/Makefile
535310 devel/phabricator/Makefile
535310 devel/phabricator/distinfo
535310 devel/phabricator/pkg-plist
Update arcanist(-lib) and phabricator to the latest stable versions.

PORTVERSIONs are the dates of the latest commits on the respective
stable branches.

Deprecate devel/libphutil, as all of its functionality has
been moved into arcanist and phabricator by upstream and
the library has been fully deprecated.
Thu, 7 May 2020
[ 20:06 mandree ] Original commit   Revision:534287
534287 UPDATING
Delete misguided mailman information.

Upstream has always told users not to modify installed files, but
to use a sitedir/ sub directory instead.
Tue, 5 May 2020
[ 07:55 tagattie ] Original commit   Revision:534035
534035 MOVED
534035 UPDATING
534035 net-im/Makefile
534035 net-im/pidgin-rocketchat
534035 net-im/purple-rocketchat
534035 net-im/purple-rocketchat/Makefile
534035 net-im/purple-rocketchat/distinfo
534035 net-im/purple-rocketchat/pkg-descr
- Rename port to net-im/purple-rocketchat from net-im/pidgin-rocketchat
- Update to 0.0.20190416
- Make portclippy happy
- Provide instructions to prevent pidgin from being autoremoved during update

PR:		244924
Submitted by:	tobias.rehbein@web.de
Approved by:	mizhka@gmail.com (maintainer), ehaupt (mentor)
Mon, 4 May 2020
[ 18:08 arrowd ] Original commit   Revision:533933
533933 Mk/Uses/cabal.mk
533933 UPDATING
533933 converters/hs-aeson-pretty/Makefile
533933 converters/hs-aeson-pretty/distinfo
533933 devel/elm-format/Makefile
533933 devel/elm-format/distinfo
533933 devel/elm-format/files/patch-elm-format.cabal
533933 devel/elm-format/files/patch-markdown_Cheapskate_ParserCombinators.hs
533933 devel/hs-alex/Makefile
533933 devel/hs-alex/distinfo

(Only the first 10 of 166 ports in this commit are shown above. View all ports for this commit)
Upgrade lang/ghc to 8.8.3 and many Haskell ports along the way.

PR:		244784
Submitted by:	Evilham <contact@evilham.com> (some ports)
Sun, 3 May 2020
[ 19:31 dvl ] Original commit   Revision:533804
533804 UPDATING
533804 net-mgmt/librenms/Makefile
533804 net-mgmt/librenms/files/librenms.in
533804 net-mgmt/librenms/files/pkg-message.in
Add support for polling as a service

Two new options

* PYPOLLER  - default, deprecated, needs Python 2.7
* PYSERVICE - Dispatcher service, recompile required

HEADS UP HEADS UP

Polling via cron job is now deprecated. Please use the Dispatcher.

LibreNMS will be dropping support for PHP 7.1 and Python 2 in the next release
expected May 31 2020.  see
https://community.librenms.org/t/dropping-support-for-php-7-1-and-python-2/11851

Your existing crontab entries for the PYPOLLER option will be going away.

You can migrate to the PYSERVICE option of LibreNMS now.

PR:		246105
Submitted by:	Dries Michiels <driesm.michiels@gmail.com>
Fri, 1 May 2020
[ 21:08 dbaio ] Original commit   Revision:533589
533589 UPDATING
Improve entry for Python 3.7 upgrade

Portmaster instruction fails under default root shell.

PR:		242964
Reported by:	Robert William Vesterman <bob@vesterman.com>
[ 07:20 flo ] Original commit   Revision:533521
533521 UPDATING
533521 www/phpmyfaq/Makefile
533521 www/phpmyfaq/distinfo
533521 www/phpmyfaq/pkg-plist
Update to 3.0.2
Tue, 28 Apr 2020
[ 20:46 bofh ] Original commit   Revision:533266
533266 UPDATING
533266 sysutils/Makefile
533266 sysutils/ansible/Makefile
533266 sysutils/ansible/distinfo
533266 sysutils/ansible23/Makefile
533266 sysutils/ansible24/Makefile
533266 sysutils/ansible25/Makefile
533266 sysutils/ansible26/Makefile
533266 sysutils/ansible27/Makefile
533266 sysutils/ansible28

(Only the first 10 of 14 ports in this commit are shown above. View all ports for this commit)
sysutils/ansible: Update version 2.8.11=>2.9.7

- Create sysutils/ansible28 from sysutils/ansible
- Set EXPIRATION_DATE to 20200530 for ansible23 ansible24 ansible25 and
  ansible26 as they are no longer maintained by upstream
- Bump ansible23 ansible24 ansible25 ansible26 and ansible27 for CONFLICTS
  with ansible28

PR:             241734
Submitted by:   ncrogers@gmail.com
Approved by:    portmgr (maintainer-timeout)
[ 10:36 jbeich ] Original commit   Revision:533244
533244 UPDATING
533244 x11-servers/xwayland-devel/pkg-message
x11-servers/xwayland-devel: drop advice obsoleted by r528071

MFH:		2020Q2 (confusing cruft removal)
Thu, 23 Apr 2020
[ 08:05 bapt ] Original commit   Revision:532651
532651 UPDATING
Fix typo and explain how to change the group for the user tests using pw(8)
Wed, 22 Apr 2020
[ 18:01 brooks ] Original commit   Revision:532493
532493 GIDs
532493 UIDs
532493 UPDATING
532493 devel/kyua/Makefile
Create and use a tests group for the tests user.

Nobody but nobody should be a member of the nobody group.

PR:		245107
Approved by:	maintainer timeout
Sponsored by:	DARPA
Fri, 17 Apr 2020
[ 23:09 mandree ] Original commit   Revision:531983
531983 UPDATING
UPDATING: caution users to backup templates/ before update when updating
mail/mailman from 2.1.29* or older.

MFH: 2020Q2 (only documentation update after r531981/MFH 531727)
Wed, 8 Apr 2020
[ 22:02 bdrewery ] Original commit   Revision:531149
531149 UPDATING
Note an upgrade issue with OpenSSH 8.2
[ 10:59 bofh ] Original commit   Revision:531106
531106 GIDs
531106 UIDs
531106 UPDATING
531106 net/irrd/Makefile
531106 net/irrd/distinfo
531106 net/irrd/files/irrd.in
531106 net/irrd/files/irrd4.in
531106 net/irrd/files/patch-config_file.c
531106 net/irrd/files/patch-configure
531106 net/irrd/files/patch-database.c

(Only the first 10 of 15 ports in this commit are shown above. View all ports for this commit)
net/irrd: Update version 2.3.10=>4.0.8

- Change LICENSE to BSD2CLAUSE from BSD4CLAUSE
- Utilizes UID and GID irrd for 252
- Take MAINTAINERSHIP
- Mentioned in UPDATING
- Both irrd-legacy and irrd can bes installed and run concurrently

Approved by:	ume (private mail)
Sat, 4 Apr 2020
[ 04:32 tcberner ] Original commit   Revision:530548
530548 UPDATING
x11/fontconfig: improve UPDATING (r530561)

Reported by:	adamw
Fri, 3 Apr 2020
[ 20:02 tcberner ] Original commit   Revision:530516
530516 UPDATING
530516 x11-fonts/fontconfig-reference/pkg-plist
530516 x11-fonts/fontconfig/Makefile
530516 x11-fonts/fontconfig/distinfo
530516 x11-fonts/fontconfig/files/patch-2.13.1.diff
530516 x11-fonts/fontconfig/files/patch-2.13.92.diff
530516 x11-fonts/fontconfig/pkg-messsage
530516 x11-fonts/fontconfig/pkg-plist
x11-fonts/fontconfig: update to 2.13.92

Fontconfig 2.13.1 generated .uuid files in the fonts directory which where
not properly registered to the packages. To clean them up, please execute the
following command:

        find %%LOCALBASE%%/share/fonts -type f -name .uuid -delete

By switching to this RC, the dependency on libuuid can be droped again, and the
issue of registering uuid is moot.

PR:		239167
Exp-run by:	antoine
Submitted by:	lightside <lightside@gmx.com>
MFH:		2020Q2
Thu, 26 Mar 2020
[ 10:03 netchild ] Original commit   Revision:529174
529174 GIDs
529174 UIDs
529174 UPDATING
529174 devel/sonar-scanner-cli/Makefile
529174 devel/sonar-scanner-cli/README.md
529174 devel/sonar-scanner-cli/distinfo
529174 devel/sonar-scanner-cli/files/pkg-message.in
529174 devel/sonar-scanner-cli/files/sonar-scanner.in
529174 devel/sonar-scanner-cli/pkg-descr
529174 devel/sonar-scanner-cli/pkg-plist

(Only the first 10 of 23 ports in this commit are shown above. View all ports for this commit)
Update sonarqube ports to the most revent version:
 - sonarqube-community: 8.2
 - sonarqube-ant-task: 2.7.0.1612
 - sonar-scanner-cli: 4.3.0.2102
Mon, 23 Mar 2020
[ 20:55 zeising ] Original commit   Revision:529003
529003 UPDATING
529003 x11/libxkbcommon/Makefile
x11/libxkbcommon: swtch to legacy rules on 11

x11/libxkbcommon was switched to use evdev rules in r528813, but FreeBSD 11
still needs the legacy rules.  Switch back to the legacy rules, but only on
FreeBSD 11.
Adjust the UPDATING entry to indicate that the switch to evdev rules by
default is only on FreeBSD 12 and later, and that FreeBSD 11 still uses the
legacy rules.
Sat, 21 Mar 2020
[ 07:24 tcberner ] Original commit   Revision:528829
528829 Mk/Uses/qca.mk
528829 UPDATING
528829 audio/amarok/Makefile
528829 audio/clementine-player/Makefile
528829 databases/kbibtex/Makefile
528829 deskutils/kdeconnect-kde/Makefile
528829 deskutils/kdepim-runtime/Makefile
528829 devel/Makefile
528829 devel/okteta/Makefile
528829 devel/qca-legacy

(Only the first 10 of 31 ports in this commit are shown above. View all ports for this commit)
devel/qca: update to 2.3

- qca-2.3 drop support for OSSL<1.1
- copy devel/qca to devel/qca-legacy which is held at the current version
- update devel/qca to 2.3
- Add Uses/qca.mk which handles dependency on either of the ports depending on
  the FreeBSD version

Users on FreeBSD11 must therefore change their pkg orign a la:

   pkg set -o devel/qca:devel/qca-legacy

PR:		244682
Exp-run by:	antoine
Reviewed by:	arrowd
Differential Revision:	https://reviews.freebsd.org/D24042
[ 00:00 zeising ] Original commit   Revision:528815
528815 UPDATING
UPDATING: Fix another typo

Fix another typo in UPDATING

Reported by:	pkubaj
Fri, 20 Mar 2020
[ 23:43 zeising ] Original commit   Revision:528814
528814 UPDATING
UPDATING: wordsmith and fix typos
[ 23:39 zeising ] Original commit   Revision:528813
528813 UPDATING
528813 x11/libxkbcommon/Makefile
528813 x11/libxkbcommon/pkg-message
x11/libxkbcommon: Switch to evdev rules by default

Switch x11/libxkbcommon to use evdev rules rather than legacy rules by
default, to improve support for keyboards when using evdev.
For users using the legacy configuration, or running xorg on FreeBSD 11,
please consult UPDATING for instructions in case of issues.

PR:		244354 [1]
Submitted by:	jbeich (fix)
Reported by:	Patricio Villar [1]
Differential Revision:	https://reviews.freebsd.org/D23860
Mon, 16 Mar 2020
[ 16:38 dmgk ] Original commit   Revision:528532
528532 UPDATING
528532 net-im/slack-term/Makefile
528532 net-im/slack-term/distinfo
528532 net-im/slack-term/files/pkg-message.in
net-im/slack-term: Update to 0.5.0

- Add UPDATING entry about config file location change
- Pet portclippy

Changes:	https://github.com/erroneousboat/slack-term/releases/tag/v0.5.0
Reported by:	portscout
Mon, 9 Mar 2020
[ 15:17 dvl ] Original commit   Revision:528107
528107 UPDATING
Fix my typo:

In other to simplify
becomes
In order to simplify

Reported by:	Reed (via private email)
Sun, 8 Mar 2020
[ 19:27 zeising ] Original commit   Revision:528071
528071 UPDATING
528071 graphics/mesa-dri/files/patch-src_egl_drivers_dri2_platform__x11.c
528071 graphics/mesa-dri/files/patch-src_glx_glxext.c
528071 graphics/mesa-libs/Makefile
528071 x11-servers/xorg-server/Makefile
graphics/mesa-libs: Change default to use DRI3

Change the default mesa configuration to use DRI3 rather than the older DRI2
interface.  This should improve performance somewhat, and alleviates the need
for the FIXDRM option in x11-servers/xorg-server.

Remove the FIXDRM option from x11-servers/xorg-server.

Add an UPDATING entry for the change.

For users of graphics/drm-legacy-kmod or the base graphics drivers, this might
cause regressions.  If you experience problems when running OpenGL applications
please force the use of the DRI2 backend by setting the LIBGL_DRI3_DISABLE
environment variable to 1 before starting any OpenGL application.  This is
easiest done by adding it to your shell startup file or .xinitrc.

Add UPDATING entry for xorg-server, detailing the change of device
configuration backend.

PR:		196678, 244306 (for tracking)
Fri, 6 Mar 2020
[ 08:26 joneum ] Original commit   Revision:527864
527864 UPDATING
Add entry for MySQL 8.0 about mysql_upgrade

Sponsored by:	Netzkommune GmbH
Wed, 4 Mar 2020
[ 19:47 pi ] Original commit   Revision:527796
527796 UPDATING
527796 net-im/prosody/Makefile
527796 net-im/prosody/files/patch-GNUmakefile
527796 net-im/prosody/files/patch-tools_migration_Makefile
527796 net-im/prosody/files/patch-util-src_time.c
527796 net-im/prosody/files/pkg-deinstall.in
527796 net-im/prosody/files/prosody.in
527796 net-im/prosody/pkg-plist
net-im/prosody: refactor and move to lua 5.2

- Use Lua 5.2 and drop support for the dead LuaJIT.
- Explicitly state all required configure options
  as the "freebsd" preset has some of them wrong.
- Do not install the example certs as they clutter the
  config directory and nobody should ever use them.
  They can be recreated with prosodyctl if needed.
- Remove the broken "daemonize" option from the rc script,
  handle all actions with "prosodyctl" instead.
- Change data directory from /usr/local/var/lib/prosody to
  /var/db/prosody and include instructions in UPDATING
- Install the prosody migrator
- Use arc4random

PR:		241619
Submitted by:	thomas@beingboiled.info
Reviewed by:	lx (maintainer), Sascha Biberhofer <ports@skyforge.at>
Approved by:	lx (maintainer timeout)
Tue, 3 Mar 2020
[ 16:25 dvl ] Original commit   Revision:527681
527681 UPDATING
527681 net-mgmt/librenms/Makefile
527681 net-mgmt/librenms/distinfo
527681 net-mgmt/librenms/files/patch-config.php.default
527681 net-mgmt/librenms/files/patch-includes_defaults.inc.php
Update to 1.61

While here, adjust the webserver options (see PR)

NOTE: upgrading existing installations will break unless you read UPGRADING
and follow the instructions.

In short:

* Apache / mod_php is no longer an option
* config.php needs entries added manually

We are jumping a few versions here:

* https://github.com/librenms/librenms/releases/tag/1.61
* https://github.com/librenms/librenms/releases/tag/1.60
* https://github.com/librenms/librenms/releases/tag/1.59
* https://github.com/librenms/librenms/releases/tag/1.58.1
* https://github.com/librenms/librenms/releases/tag/1.58

PR:		235949
Submitted by:	Dries Michiels <driesm.michiels@gmail.com>
Sat, 29 Feb 2020
[ 13:17 mfechner ] Original commit   Revision:527417
527417 UPDATING
527417 textproc/apache-solr/Makefile
527417 textproc/apache-solr/distinfo
527417 textproc/apache-solr/pkg-plist
textproc/apache-solr: security related update to 8.4.1
Switch java version to current LTS version.

MFH:		2020Q1
Security:	e59cb761-5ad8-11ea-abb7-001b217b3468
Tue, 25 Feb 2020
[ 22:19 kai ] Original commit   Revision:527141
527141 UPDATING
527141 net-mgmt/netbox/Makefile
527141 net-mgmt/netbox/distinfo
527141 net-mgmt/netbox/files/pkg-message.in
527141 net-mgmt/netbox/pkg-plist
net-mgmt/netbox: Update to 2.7.7

* Remove the "post-patch" target because the "requirements.txt" is only used
  for installations via devel/py-pip.

Notable changes since 2.6.12:

* Bulk import of device components via CSV files
* External file storage support (FTP, S3, SFTP, etc.)
* Rack elevations rendered by SVG (= Scalable Vector Graphics)
* Separate configuration for Webhooks and Cache databases via Redis
* Add ability to clone objects (pre-populate form fields)
* Toggle config context display between JSON and YAML
* Add support for Redis Sentinel
* Further cable and port types
* Many other enhancements and bugfixes

https://github.com/netbox-community/netbox/blob/v2.7.7/docs/release-notes/version-2.7.md
Sun, 23 Feb 2020
[ 10:51 zeising ] Original commit   Revision:526915
526915 UPDATING
UPDATING: improve xorg-server entry

Improve the xorg-server entry a bit, add a note about needing
xf86-input-libinput and x11/libinput, since they seem to not always be
installed when people have custom configs or options.
[ 08:08 sunpoet ] Original commit   Revision:526899
526899 UPDATING
Document the split of GNU SASL (gsasl)
Thu, 20 Feb 2020
[ 22:26 zeising ] Original commit   Revision:526594
526594 UPDATING
Add UPDATING entry for xorg-server

Add UPDATING entry for xorg-server, detailing the change of device
configuration backend.

Reminded by:	linimon, grembo
PR:		196678 (for tracking)
Fri, 7 Feb 2020
[ 13:32 lwhsu ] Original commit   Revision:525484
525484 UPDATING
525484 security/nss/Makefile
525484 security/nss/files/nss-config.in
525484 security/nss/files/nss.pc.in
525484 security/nss/pkg-plist
Reduce the duplicated 'nss' in include and lib path

From jbeich:
This appeared after r78824 which failed to adjust do-install.  Arch, Debian,
Gentoo, OpenBSD use include/nss/, Fedora uses include/nss3/, NetBSD/PkgSrc
uses include/nss/nss/.

PR:		243835
Reviewed by:	jbeich
Differential Revision:	https://reviews.freebsd.org/D23424
Tue, 4 Feb 2020
[ 14:03 adamw ] Original commit   Revision:525167
525167 UPDATING
525167 editors/vim/Makefile
525167 editors/vim/distinfo
vim: Update to patchlevel 205 and add PYTHON option

When python is built with DEBUG, vim fails to build. In fixing this
case, note that vim will now fail to build if python or vim is build
with DEBUG and the other isn't.

This also highlighted that python support is being kludged. The
PYTHON2 and PYTHON3 options have been combined into a single PYTHON
option that builds with the default python. Consequently, it is no
longer possible to build vim with both py2 and py3 support. I can't
name any modern high-usage python-based plugin that requires 2.7,
so hopefully this only messes up things for a very small minority.

Thanks to koobs for the prompt to combine these options. I've been
wanting to do this for a while now.

PR:		243606
Submitted by:	novel
Thu, 30 Jan 2020
[ 05:04 lwhsu ] Original commit   Revision:524628
524628 UPDATING
Remove trailing whitespace
Mon, 27 Jan 2020
[ 19:47 netchild ] Original commit   Revision:524410
524410 UPDATING
Improve the 20191216 entry. This may or may not cover the 20200113 entry.
At least it covers some cases like gdb or gobject-introspection I
encountered.
Sun, 26 Jan 2020
[ 17:42 kwm ] Original commit   Revision:524224
524224 MOVED
524224 Mk/bsd.gstreamer.mk
524224 UPDATING
524224 audio/Makefile
524224 audio/gstreamer1-plugins-pulse/Makefile
524224 audio/gstreamer1-plugins-spc
524224 audio/gstreamer1-plugins-webrtcdsp/Makefile
524224 devel/orc/Makefile
524224 devel/orc/distinfo
524224 devel/orc/files/patch-orc-orccpu_powerpc.c

(Only the first 10 of 82 ports in this commit are shown above. View all ports for this commit)
Update gstreamer1 to 1.16.2.

- The spc plugin was removed inflavor for the gsm plugin.
- Added in tree qt plugin.

Changelog: https://gstreamer.freedesktop.org/releases/1.16/#1.16.2

Update net-im/fractal to 4.2.2 to support GStreamer 1.16 (approved by
maintainer)

Thanks to antoine@ for the exp-run.

PR:		239386

Number of commits found XX: 2430 (showing only 100 on this page)

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11  »  [Last Page]

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
gitlab-ceMar 05
asterisk16Mar 04
asterisk18Mar 04
chromiumMar 04
jasperMar 03
py-saltMar 03
vaultFeb 27
redisFeb 23
redis-develFeb 23
redis5Feb 23
zeekFeb 22
jenkinsFeb 20
raptor2Feb 20
asterisk13Feb 18
asterisk13Feb 18

10 vulnerabilities affecting 79 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2021-03-05 21:21:29


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 42671
Broken 75
Deprecated 167
Ignore 313
Forbidden 4
Restricted 139
No CDROM 71
Vulnerable 20
Expired 37
Set to expire 143
Interactive 0
new 24 hours 0
new 48 hours6
new 7 days46
new fortnight89
new month153

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2021 Dan Langille. All rights reserved.